aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/phalanx/phalanx_22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/phalanx/phalanx_22.bb')
-rw-r--r--recipes/phalanx/phalanx_22.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/phalanx/phalanx_22.bb b/recipes/phalanx/phalanx_22.bb
new file mode 100644
index 0000000000..a59a696809
--- /dev/null
+++ b/recipes/phalanx/phalanx_22.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Phalanx is a chess playing engine."
+SECTION = "opie/libs"
+PRIORITY = "optional"
+PR = "r4"
+LICENSE = "GPL"
+SRC_URI = "http://ftp.debian.org/debian/pool/main/p/phalanx/phalanx_22.orig.tar.gz \
+ file://gcc3.patch;patch=1 \
+ file://capabilities \
+ file://description"
+S = "${WORKDIR}/phalanx-22.orig"
+
+do_compile() {
+ oe_runmake CC="${CC}" CFLAGS="${CFLAGS}" STRIP=echo LD="${CC}"
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/chess/engines/Phalanx
+ install -D -m 755 phalanx ${D}${palmtopdir}/chess/engines/Phalanx/phalanx
+ install -D -m 755 pbook.phalanx ${D}${palmtopdir}/chess/engines/Phalanx/pbook.phalanx
+ >${D}${palmtopdir}/chess/engines/Phalanx/sbook.phalanx
+ >${D}${palmtopdir}/chess/engines/Phalanx/learn.phalanx
+ install -D -m 755 ${WORKDIR}/capabilities ${D}${palmtopdir}/chess/engines/Phalanx/capabilities
+ install -D -m 755 ${WORKDIR}/description ${D}${palmtopdir}/chess/engines/Phalanx/description
+}
+
+FILES_${PN} = "${palmtopdir}/chess"
+FILES_${PN}-dbg += "${palmtopdir}/chess/engines/Phalanx/.debug"