aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/picocom/picocom_1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/picocom/picocom_1.4.bb')
-rw-r--r--recipes/picocom/picocom_1.4.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/picocom/picocom_1.4.bb b/recipes/picocom/picocom_1.4.bb
new file mode 100644
index 0000000000..c13bdabcc3
--- /dev/null
+++ b/recipes/picocom/picocom_1.4.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Lightweight and minimal (~20K) dumb-terminal emulation program."
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "http://efault.net/npat/hacks/picocom/dist/picocom-${PV}.tar.gz \
+ file://nolock.patch;patch=1 \
+ file://gcc4.patch;patch=1"
+
+CFLAGS_append = ' -DVERSION_STR=\\"${PV}\\"'
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 ${PN} pcasc pcxm pcym pczm ${D}${bindir}/
+}