aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/podget
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/podget')
-rw-r--r--recipes/podget/podget-0.5.8/busybox_df.patch11
-rw-r--r--recipes/podget/podget_0.5.8.bb16
2 files changed, 27 insertions, 0 deletions
diff --git a/recipes/podget/podget-0.5.8/busybox_df.patch b/recipes/podget/podget-0.5.8/busybox_df.patch
new file mode 100644
index 0000000000..1f84558d92
--- /dev/null
+++ b/recipes/podget/podget-0.5.8/busybox_df.patch
@@ -0,0 +1,11 @@
+--- podget/podget~ 2008-05-08 08:50:23.000000000 +0000
++++ podget/podget 2008-05-08 08:50:37.000000000 +0000
+@@ -535,7 +535,7 @@
+ url_base=$(echo $url | sed -e 's/\(.*\/\)[^\/]\+/\1/')
+
+ # Test for available space on library partition
+- avail_space=$(df -kP ${dir_library} | tail -n 1 | awk '{print $4}')
++ avail_space=$(df -k ${dir_library} | tail -n 1 | awk '{print $4}')
+ if [ ${avail_space} -le ${min_space} ] ; then
+ echo -e "\nAvailable space on Library partition has dropped below allowed.\nStopping Session."
+ exit 1
diff --git a/recipes/podget/podget_0.5.8.bb b/recipes/podget/podget_0.5.8.bb
new file mode 100644
index 0000000000..4af771e153
--- /dev/null
+++ b/recipes/podget/podget_0.5.8.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "A simple podcast aggregator."
+HOMEPAGE = "http://podget.sourceforge.net/"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+RDEPENDS = "bash sed wget libiconv"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/podget/podget_${PV}.tar.gz \
+ file://busybox_df.patch;patch=1"
+
+S = "${WORKDIR}/podget"
+
+do_install () {
+ install -d ${D}/usr/bin
+ install -m 0755 ${WORKDIR}/podget/podget ${D}/usr/bin
+}