aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/policykit
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/policykit')
-rw-r--r--recipes/policykit/policykit-gnome_0.9.2.bb23
-rw-r--r--recipes/policykit/policykit_0.9.bb38
2 files changed, 61 insertions, 0 deletions
diff --git a/recipes/policykit/policykit-gnome_0.9.2.bb b/recipes/policykit/policykit-gnome_0.9.2.bb
new file mode 100644
index 0000000000..0044c8a53c
--- /dev/null
+++ b/recipes/policykit/policykit-gnome_0.9.2.bb
@@ -0,0 +1,23 @@
+HOMEPAGE = "http://www.packagekit.org/"
+DEPENDS = "policykit libgnome"
+
+SRC_URI = "http://hal.freedesktop.org/releases/PolicyKit-gnome-${PV}.tar.bz2 \
+ "
+
+EXTRA_OECONF = " --disable-scrollkeeper \
+ --disable-man-pages \
+ --disable-examples \
+ --disable-gtk-doc"
+
+S = "${WORKDIR}/PolicyKit-gnome-${PV}"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += " ${datadir}/dbus-1 \
+ ${datadir}/PolicyKit \
+ "
+
diff --git a/recipes/policykit/policykit_0.9.bb b/recipes/policykit/policykit_0.9.bb
new file mode 100644
index 0000000000..c7ba718105
--- /dev/null
+++ b/recipes/policykit/policykit_0.9.bb
@@ -0,0 +1,38 @@
+HOMEPAGE = "http://www.packagekit.org/"
+DEPENDS = "libpam expat dbus-glib"
+
+PR = "r3"
+
+SRC_URI = "http://hal.freedesktop.org/releases/PolicyKit-${PV}.tar.gz"
+
+EXTRA_OECONF = "--with-authfw=pam --with-os-type=moblin --disable-man-pages --disable-gtk-doc"
+
+S = "${WORKDIR}/PolicyKit-${PV}"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += " ${datadir}/dbus-1 \
+ ${datadir}/PolicyKit \
+ "
+
+pkg_postinst_${PN} () {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+ grep "^polkituser:" /etc/group > /dev/null || addgroup polkituser
+ grep "^polkituser:" /etc/passwd > /dev/null || adduser --disabled-password --system --home /var/run/polkit polkituser --ingroup polkituser -g polkituser
+ DBUSPID=`pidof dbus-daemon`
+ if [ "x$DBUSPID" != "x" ]; then
+ /etc/init.d/dbus-1 force-reload
+ fi
+}
+
+pkg_postrm_${PN} () {
+ deluser polkituser || true
+ delgroup polkituser || true
+}