aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/povray/povray-3.6.1+3.7.0-beta25b
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/povray/povray-3.6.1+3.7.0-beta25b')
-rw-r--r--recipes/povray/povray-3.6.1+3.7.0-beta25b/configure-cross-hack.patch42
-rw-r--r--recipes/povray/povray-3.6.1+3.7.0-beta25b/gcc43.diff70
2 files changed, 112 insertions, 0 deletions
diff --git a/recipes/povray/povray-3.6.1+3.7.0-beta25b/configure-cross-hack.patch b/recipes/povray/povray-3.6.1+3.7.0-beta25b/configure-cross-hack.patch
new file mode 100644
index 0000000000..e0803bafac
--- /dev/null
+++ b/recipes/povray/povray-3.6.1+3.7.0-beta25b/configure-cross-hack.patch
@@ -0,0 +1,42 @@
+--- /tmp/configure.ac 2008-08-14 01:13:37.000000000 +0200
++++ povray-3.7.0.beta.25b/configure.ac 2008-08-14 01:17:56.253198000 +0200
+@@ -357,8 +357,6 @@
+ AC_MSG_RESULT([yes])
+ AX_CHECK_LIB([z], [$required_libz_version], [z], [zlibVersion], [zlib.h], [zlibVersion()], [$with_zlib])
+ if test x"$ax_check_lib" != x"ok"; then
+- AC_MSG_ERROR([cannot find a suitable ZLIB library])
+- else
+ pov_libz=ok
+ fi
+ fi
+@@ -373,8 +371,6 @@
+ AC_MSG_RESULT([yes])
+ AX_CHECK_LIB([png], [$required_libpng_version], [png12 png], [png_get_libpng_ver], [png.h], [png_get_libpng_ver(NULL)], [$with_libpng])
+ if test x"$ax_check_lib" != x"ok"; then
+- AC_MSG_ERROR([cannot find a suitable PNG library])
+- else
+ pov_libpng=ok
+ fi
+ fi
+@@ -390,11 +386,9 @@
+ AC_MSG_RESULT([yes])
+ AX_CHECK_LIBJPEG([$required_libjpeg_version], [$with_libjpeg])
+ if test x"$ax_check_libjpeg" != x"ok"; then
+- AC_MSG_ERROR([cannot find a suitable JPEG library])
+- else
+ # create jversion.h in builddir
+ test -d "./source" || mkdir ./source
+- echo "#define JVERSION \"${ax_check_libjpeg_version}\"" > ./source/jversion.h
++ echo "#define JVERSION \"62\"" > ./source/jversion.h
+ pov_libjpeg=ok
+ fi
+ fi
+@@ -409,8 +403,6 @@
+ AC_MSG_RESULT([yes])
+ AX_CHECK_LIBTIFF([$required_libtiff_version], [$with_libtiff])
+ if test x"$ax_check_libtiff" != x"ok"; then
+- AC_MSG_ERROR([cannot find a suitable TIFF library])
+- else
+ pov_libtiff=ok
+ fi
+ fi
diff --git a/recipes/povray/povray-3.6.1+3.7.0-beta25b/gcc43.diff b/recipes/povray/povray-3.6.1+3.7.0-beta25b/gcc43.diff
new file mode 100644
index 0000000000..696dfb471f
--- /dev/null
+++ b/recipes/povray/povray-3.6.1+3.7.0-beta25b/gcc43.diff
@@ -0,0 +1,70 @@
+--- /tmp/processoptions.cpp 2008-08-14 01:47:37.000000000 +0200
++++ povray-3.7.0.beta.25b/source/base/processoptions.cpp 2008-08-14 01:48:23.853198000 +0200
+@@ -90,6 +90,7 @@
+ *
+ *********************************************************************************/
+
++#include <cstring>
+ #include <cstdarg>
+ #include <cctype>
+
+--- /tmp/fileinputoutput.cpp 2008-08-14 01:49:16.000000000 +0200
++++ povray-3.7.0.beta.25b/source/base/fileinputoutput.cpp 2008-08-14 01:49:33.043198000 +0200
+@@ -90,6 +90,7 @@
+ *
+ *********************************************************************************/
+
++#include <cstring>
+ #include <cstdlib>
+ #include <cstdarg>
+
+--- /tmp/textstreambuffer.cpp 2008-08-14 01:52:07.000000000 +0200
++++ povray-3.7.0.beta.25b/source/base/textstreambuffer.cpp 2008-08-14 01:52:21.693198000 +0200
+@@ -90,6 +90,7 @@
+ *
+ *********************************************************************************/
+
++#include <cstring>
+ #include <algorithm>
+
+ #include "configbase.h"
+--- /tmp/fileinputoutput.h 2008-08-14 01:53:49.000000000 +0200
++++ povray-3.7.0.beta.25b/source/base/fileinputoutput.h 2008-08-14 01:54:07.213198000 +0200
+@@ -96,6 +96,7 @@
+ #include "base/types.h"
+ #include "base/path.h"
+
++#include <cstring>
+ #include <string>
+
+ namespace pov_base
+--- /tmp/configbase.h 2008-08-14 01:57:58.000000000 +0200
++++ povray-3.7.0.beta.25b/source/base/configbase.h 2008-08-14 01:58:12.373198000 +0200
+@@ -95,6 +95,7 @@
+ #ifndef CONFIGBASE_H
+ #define CONFIGBASE_H
+
++#include <climits>
+ #include "syspovconfigbase.h"
+
+ #ifndef DBL
+--- /tmp/unixoptions.cpp 2008-08-14 02:02:52.000000000 +0200
++++ povray-3.7.0.beta.25b/vfe/unix/unixoptions.cpp 2008-08-14 10:22:09.073198000 +0200
+@@ -454,13 +454,16 @@
+ char *errormsg =
+ "Cannot determine the current working directory.\n"
+ "Check that the PWD environment variable does exist and is valid.\n";
++ int no_error_call = 1;
+ if(no_error_call)
+ {
+ fprintf(stderr, "%s: %s\n", PACKAGE, errormsg);
+ exit(EXIT_FAILURE);
+ }
++#ifdef USE_ERROR
+ else
+- Error("%s", errormsg);
++ std::Error("%s", errormsg);
++#endif
+ }
+ #endif
+