aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ppp/ppp_2.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ppp/ppp_2.4.1.bb')
-rw-r--r--recipes/ppp/ppp_2.4.1.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes/ppp/ppp_2.4.1.bb b/recipes/ppp/ppp_2.4.1.bb
new file mode 100644
index 0000000000..77cce50117
--- /dev/null
+++ b/recipes/ppp/ppp_2.4.1.bb
@@ -0,0 +1,48 @@
+SECTION = "console/network"
+DESCRIPTION = "Point-to-Point Protocol (PPP) daemon"
+HOMEPAGE = "http://samba.org/ppp/"
+LICENSE = "BSD GPLv2"
+PR = "r7"
+
+SRC_URI = "http://ppp.samba.org/ftp/ppp/ppp-${PV}.tar.gz \
+ file://pppd.patch;patch=1 \
+ file://man.patch;patch=1 \
+ file://cifdefroute.dif;patch=1 \
+ file://pppd-resolv-varrun.patch;patch=1 \
+ file://pon \
+ file://poff \
+ file://init \
+ file://ip-up \
+ file://ip-down \
+ file://08setupdns \
+ file://92removedns"
+
+SRC_URI_append_nylon = " file://ppp-tdbread.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OEMAKE = "STRIPPROG=${STRIP}"
+EXTRA_OECONF = "--disable-strip"
+
+do_install_append () {
+ install -d ${D}${bindir}/ ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/pon ${D}${bindir}/pon
+ install -m 0755 ${WORKDIR}/poff ${D}${bindir}/poff
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ppp
+ install -m 0755 ${WORKDIR}/ip-up ${D}${sysconfdir}/ppp/
+ install -m 0755 ${WORKDIR}/ip-down ${D}${sysconfdir}/ppp/
+ install -d ${D}${sysconfdir}/ppp/ip-up.d/
+ install -d ${D}${sysconfdir}/ppp/ip-down.d/
+ install -m 0755 ${WORKDIR}/08setupdns ${D}${sysconfdir}/ppp/ip-up.d/
+ install -m 0755 ${WORKDIR}/92removedns ${D}${sysconfdir}/ppp/ip-down.d/
+}
+
+CONFFILES_${PN} = "${sysconfdir}/ppp/pap-secrets ${sysconfdir}/ppp/chap-secrets ${sysconfdir}/ppp/options"
+
+pkg_postinst() {
+if test "x$D" != "x"; then
+ exit 1
+else
+ chmod u+s ${sbindir}/pppd
+fi
+}