summaryrefslogtreecommitdiffstats
path: root/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/libgps-check.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/libgps-check.patch')
-rw-r--r--recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/libgps-check.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/libgps-check.patch b/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/libgps-check.patch
new file mode 100644
index 0000000000..613adb2255
--- /dev/null
+++ b/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/libgps-check.patch
@@ -0,0 +1,57 @@
+Index: prismstumbler-0.7.4pre1/configure.ac
+===================================================================
+--- prismstumbler-0.7.4pre1.orig/configure.ac
++++ prismstumbler-0.7.4pre1/configure.ac
+@@ -137,51 +137,11 @@ AC_ARG_ENABLE(static-libgps,
+ ], [ static_libgps="no"]
+ )
+
+-AC_MSG_CHECKING(for libgps)
+-AC_ARG_WITH(libgps,
+-[ --with-libgps=DIR use libgps in DIR],
+-[ case "$withval" in
+- *)
+- AC_MSG_RESULT($withval)
+- if test -f $withval/include/gps.h -a -f $withval/lib/libgps.a; then
+- owd=`pwd`
+- if cd $withval; then withval=`pwd`; cd $owd; fi
+- libgps_dir=${withval}
+- GPSD_CFLAGS="-I$withval/include"
+- if test "x$static_libgps" = "xyes"; then
+- GPSD_LIBS="-lm -lpthread $withval/lib/libgps.a"
+- else
+- GPSD_LIBS="-L$withval/lib -lgps"
+- fi
+- else
+- AC_ERROR(libgps not found in $withval prefix)
+- fi
+- ;;
+- esac ],
+-[
+- for dir in ${prefix} ${prefix}/local /usr /usr/local; do
+- if test -f ${dir}/include/gps.h -a -f ${dir}/lib/libgps.a; then
+- libgps_dir=${dir}
+- GPSD_CFLAGS="-I${dir}/include"
+- if test "x$static_libgps" = "xyes"; then
+- GPSD_LIBS="-lm -lpthread ${dir}/lib/libgps.a"
+- else
+- GPSD_LIBS="-L${dir}/lib -lgps"
+- fi
+- fi
+- done
+- if test -z ${libgps_dir}; then
+- AC_MSG_RESULT(no)
+- AC_ERROR(libgps not found)
+- fi
+- AC_MSG_RESULT(yes) ]
+-)
++PKG_CHECK_MODULES([GPSD], [libgps])
+
+ if test -z "$GPSD_CFLAGS"; then
+ AC_ERROR("libgps not found")
+ fi
+-AC_SUBST(GPSD_CFLAGS)
+-AC_SUBST(GPSD_LIBS)
+
+
+ dnl Checks for wireless lib