aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/proftpd/proftpd_1.3.3c.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/proftpd/proftpd_1.3.3c.bb')
-rw-r--r--recipes/proftpd/proftpd_1.3.3c.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/proftpd/proftpd_1.3.3c.bb b/recipes/proftpd/proftpd_1.3.3c.bb
new file mode 100644
index 0000000000..63b5b2c397
--- /dev/null
+++ b/recipes/proftpd/proftpd_1.3.3c.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Secure ftp daemon"
+SECTION = "console/network"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "ftp://ftp.nl.uu.net/pub/unix/ftp/proftpd/ftp/distrib/source/${PN}-${PV}.tar.gz \
+ file://make.patch \
+ file://proftpd-install-nostrip.patch \
+ "
+
+
+EXTRA_OECONF = "ac_cv_func_setpgrp_void=yes ac_cv_func_setgrent_void=yes --disable-cap"
+LDFLAGS += "-Llib"
+PARALLEL_MAKE = ""
+
+do_configure () {
+ ./configure \
+ --disable-auth-pam \
+ --build=${BUILD_SYS} \
+ --host=${HOST_SYS} \
+ --target=${TARGET_SYS} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --sharedstatedir=/com \
+ --localstatedir=/var \
+ ${EXTRA_OECONF} \
+ $@;
+}
+
+pkg_postinst () {
+ # more chown's might be needed
+ chown root:root /usr/sbin/proftpd
+}