aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pth/pth_2.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/pth/pth_2.0.2.bb')
-rw-r--r--recipes/pth/pth_2.0.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/pth/pth_2.0.2.bb b/recipes/pth/pth_2.0.2.bb
new file mode 100644
index 0000000000..81b8a71b63
--- /dev/null
+++ b/recipes/pth/pth_2.0.2.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "GNU Portable Threads"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+PR = "r1"
+
+SRC_URI = "${GNU_MIRROR}/pth/pth-${PV}.tar.gz \
+ file://m4-warning.patch;patch=1 \
+ "
+
+PARALLEL_MAKE=""
+
+inherit autotools
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_stage() {
+ oe_libinstall -so libpth ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/
+ for X in pth.h
+ do
+ install -m 0644 ${S}/$X ${STAGING_INCDIR}/$X
+ done
+
+ install -d ${STAGING_DATADIR}/aclocal
+ install pth.m4 ${STAGING_DATADIR}/aclocal/
+}