aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pthsem/pthsem_2.0.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/pthsem/pthsem_2.0.7.bb')
-rw-r--r--recipes/pthsem/pthsem_2.0.7.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/pthsem/pthsem_2.0.7.bb b/recipes/pthsem/pthsem_2.0.7.bb
new file mode 100644
index 0000000000..30e2f176e0
--- /dev/null
+++ b/recipes/pthsem/pthsem_2.0.7.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "GNU Portable Threads replacement with semaphore support"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+PR = "r0"
+
+SRC_URI = "https://www.auto.tuwien.ac.at/~mkoegler/pth/pthsem-${PV}.tar.gz \
+ file://ldflags.patch;patch=1 \
+ "
+
+inherit autotools binconfig
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+do_install_prepend() {
+ cp ${S}/pth-config ${S}/pthsem-config
+}
+do_stage() {
+ oe_libinstall -so libpthsem ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/
+ install -m 0644 ${S}/pth.h ${STAGING_INCDIR}/pthsem.h
+ install -d ${STAGING_BINDIR}/
+ install -d ${STAGING_DATADIR}/aclocal
+ install pth.m4 ${STAGING_DATADIR}/aclocal/pthsem.m4
+}
+
+BINCONFIG_GLOB = "pthsem-config"
+
+PARALLEL_MAKE = ""