aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pwc/pwc_10.0.12-rc1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/pwc/pwc_10.0.12-rc1.bb')
-rw-r--r--recipes/pwc/pwc_10.0.12-rc1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/pwc/pwc_10.0.12-rc1.bb b/recipes/pwc/pwc_10.0.12-rc1.bb
new file mode 100644
index 0000000000..4292f5c717
--- /dev/null
+++ b/recipes/pwc/pwc_10.0.12-rc1.bb
@@ -0,0 +1,35 @@
+# FIXME, consider using kernel staging directory instead of KERNEL_SOURCE which is
+# located in the work directory. see module.bbclass
+
+DESCRIPTION = "Philips USB Webcam driver for Linux that supports VGA resolution"
+HOMEPAGE = "http://www.saillard.org/linux/pwc"
+PRIORITY = "optional"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.saillard.org/linux/pwc/files/pwc-${PV}.tar.bz2 \
+ file://Makefile.patch;patch=1"
+
+S = "${WORKDIR}/pwc-${PV}"
+
+inherit module
+
+CFLAGS = "'-I${KERNEL_SOURCE}/include' "
+
+CFLAGS_append_arm = " '-D__LINUX_ARM_ARCH__=5' "
+
+CFLAGS_append_armeb = " '-D__LINUX_ARM_ARCH__=5' "
+
+EXTRA_OEMAKE = "'V=1' 'CFLAGS=${CFLAGS}' \
+ 'CC=${KERNEL_CC}' \
+ 'LD=${KERNEL_LD}' \
+ 'KDIR=${STAGING_KERNEL_DIR}'"
+
+export TARGET_LDFLAGS = "-L${STAGING_DIR_TARGET}${layout_libdir} \
+ -rpath-link ${STAGING_DIR_TARGET}${layout_libdir}"
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+ install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+}