aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pxaregs/pxaregs_1.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/pxaregs/pxaregs_1.14.bb')
-rw-r--r--recipes/pxaregs/pxaregs_1.14.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/pxaregs/pxaregs_1.14.bb b/recipes/pxaregs/pxaregs_1.14.bb
new file mode 100644
index 0000000000..d57dacef51
--- /dev/null
+++ b/recipes/pxaregs/pxaregs_1.14.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Tool to display and modify PXA registers at runtime"
+LICENSE = "GPLv2"
+AUTHOR = "Holger Schurig <hs4233@mail.mn-solutions.de>"
+HOMEPAGE = "http://www.mn-logistik.de/unsupported/pxa250/"
+
+SRC_URI = "http://www.mn-logistik.de/unsupported/pxa250/pxaregs.c \
+ file://i2c.patch;pnum=1;patch=1 \
+ file://munmap.patch;pnum=1;patch=1 \
+ file://serial.patch;pnum=1;patch=1 \
+ file://usb.patch;pnum=1;patch=1 "
+
+S = "${WORKDIR}"
+
+do_compile() {
+ ${CC} pxaregs.c -o pxaregs ${CFLAGS}
+}
+
+do_install() {
+ install -d ${D}${sbindir}/
+ install -m 0755 pxaregs ${D}${sbindir}/
+}