aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-2.7.1/01-fix-have-long-long-format.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-2.7.1/01-fix-have-long-long-format.patch')
-rw-r--r--recipes/python/python-2.7.1/01-fix-have-long-long-format.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/python/python-2.7.1/01-fix-have-long-long-format.patch b/recipes/python/python-2.7.1/01-fix-have-long-long-format.patch
new file mode 100644
index 0000000000..6cf3cd4959
--- /dev/null
+++ b/recipes/python/python-2.7.1/01-fix-have-long-long-format.patch
@@ -0,0 +1,19 @@
+# The configure script assumes the %lld printf format is not available as it
+# can't run its check script. For some reason python refuses to compile without
+# this functionality, so we just assume that our printf supports %lld.
+#
+# Include/pyport.h:243:13: error: #error "This platform's pyconfig.h needs to define PY_FORMAT_LONG_LONG"
+
+Index: Python-2.7.1/configure.in
+===================================================================
+--- Python-2.7.1.orig/configure.in
++++ Python-2.7.1/configure.in
+@@ -4151,7 +4151,7 @@ then
+ ]]])],
+ [ac_cv_have_long_long_format=yes],
+ [ac_cv_have_long_long_format=no],
+- [ac_cv_have_long_long_format=no])
++ [ac_cv_have_long_long_format=yes])
+ )
+ AC_MSG_RESULT($ac_cv_have_long_long_format)
+ fi