summaryrefslogtreecommitdiffstats
path: root/recipes/python/python-django_1.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-django_1.0.2.bb')
-rw-r--r--recipes/python/python-django_1.0.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/python/python-django_1.0.2.bb b/recipes/python/python-django_1.0.2.bb
new file mode 100644
index 0000000000..0c572eeeda
--- /dev/null
+++ b/recipes/python/python-django_1.0.2.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Python Web framework"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "BSD"
+SRCNAME = "Django"
+PR = "ml0"
+
+SRC_URI = "http://media.djangoproject.com/releases/${PV}/${SRCNAME}-${PV}-final.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}-final"
+
+inherit distutils
+
+DISTUTILS_INSTALL_ARGS = "--root=${D} --prefix=${prefix}"
+
+# TODO: huge package, increase granularity
+
+RDEPENDS_${PN} = "\
+ python-email \
+ python-netserver \
+ python-pickle \
+ python-pprint \
+ python-shell \
+ python-sqlite \
+ python-textutils \
+ python-threading \
+ python-unixadmin \
+ python-xml \
+"