aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-efl.inc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-efl.inc')
-rw-r--r--recipes/python/python-efl.inc14
1 files changed, 11 insertions, 3 deletions
diff --git a/recipes/python/python-efl.inc b/recipes/python/python-efl.inc
index 745ba57cc6..9845fbff36 100644
--- a/recipes/python/python-efl.inc
+++ b/recipes/python/python-efl.inc
@@ -10,11 +10,20 @@ RDEPENDS_${PN} += "python-lang"
PV = "0.3.1+svnr${SRCPV}"
PR = "ml1"
-inherit setuptools
+# necessary to let the call for python-config succeed
+export BUILD_SYS
+export HOST_SYS
+
+inherit autotools pkgconfig distutils-base
SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/BINDINGS/python;module=${PN};proto=http"
S = "${WORKDIR}/${PN}"
+do_configure_prepend() {
+ # prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly
+ sed -i "s#\`\$PKG_CONFIG --variable=includedir \"python-evas#${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac
+}
+
do_install_append() {
if [ -e examples ]; then
for i in `find examples -name "*.edc"`; do
@@ -27,8 +36,7 @@ do_install_append() {
cd ${S}
install -d ${D}${datadir}/${PN}/
cp -a examples ${D}${datadir}/${PN}/
- find ${D}${datadir}/${PN}/examples -name "CVS" | xargs rm -rf
- find ${D}${datadir}/${PN}/examples -name ".cvsignore" | xargs rm -f
+ find ${D}${datadir}/${PN}/examples -name ".svn" | xargs rm -rf
fi
}