aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-pygtk_2.8.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-pygtk_2.8.6.bb')
-rw-r--r--recipes/python/python-pygtk_2.8.6.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/python/python-pygtk_2.8.6.bb b/recipes/python/python-pygtk_2.8.6.bb
new file mode 100644
index 0000000000..4e7e22b159
--- /dev/null
+++ b/recipes/python/python-pygtk_2.8.6.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Python GTK+ Bindings"
+SECTION = "devel/python"
+PRIORITY = "optional"
+# needs gtk+ 2.8.x
+DEPENDS = "gtk+-2.8.16 libglade"
+RDEPENDS = "python-shell"
+SRCNAME = "pygtk"
+LICENSE = "LGPL"
+PR = "r2"
+
+MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/${MAJ_VER}/${SRCNAME}-${PV}.tar.bz2 \
+ file://acinclude.m4"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit autotools pkgconfig distutils-base
+
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+}
+
+do_stage() {
+ autotools_stage_includes
+ install -m 0755 codegen/pygtk-codegen-2.0 ${STAGING_BINDIR_NATIVE}/
+}