aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-pyode_1.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-pyode_1.2.0.bb')
-rw-r--r--recipes/python/python-pyode_1.2.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/python/python-pyode_1.2.0.bb b/recipes/python/python-pyode_1.2.0.bb
new file mode 100644
index 0000000000..be4b38acd5
--- /dev/null
+++ b/recipes/python/python-pyode_1.2.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "PyODE is a set of open-source Python bindings for The Open Dynamics Engine, \
+an open-source physics engine. PyODE also includes an XODE parser."
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "ode"
+SRCNAME = "PyODE"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pyode/${SRCNAME}-${PV}.tar.bz2 \
+ file://install.patch;patch=1"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_configure_prepend() {
+ ln -s ${STAGING_LIBDIR}/.. ../ode
+}
+