aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-scapy_2.0.0.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-scapy_2.0.0.9.bb')
-rw-r--r--recipes/python/python-scapy_2.0.0.9.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/python/python-scapy_2.0.0.9.bb b/recipes/python/python-scapy_2.0.0.9.bb
new file mode 100644
index 0000000000..ebe1223418
--- /dev/null
+++ b/recipes/python/python-scapy_2.0.0.9.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Scapy is a powerful interactive packet manipulation tool, \
+packet generator, network scanner, network discovery, packet sniffer, etc. \
+It can for the moment replace hping, 85% of nmap, arpspoof, arp-sk, arping, \
+tcpdump, tethereal, p0f, ...."
+SECTION = "devel/python"
+HOMEPAGE = "http://www.secdev.org/projects/scapy/"
+LICENSE = "GPL"
+PRIORITY = "optional"
+SRCNAME = "scapy"
+PR = "ml1"
+
+SRC_URI = "http://www.secdev.org/projects/scapy/files/scapy-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+RDEPENDS = "\
+ python-netclient \
+ python-netserver \
+"