aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-scons-native_1.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-scons-native_1.2.0.bb')
-rw-r--r--recipes/python/python-scons-native_1.2.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes/python/python-scons-native_1.2.0.bb b/recipes/python/python-scons-native_1.2.0.bb
new file mode 100644
index 0000000000..31bce5583d
--- /dev/null
+++ b/recipes/python/python-scons-native_1.2.0.bb
@@ -0,0 +1,14 @@
+require python-scons_${PV}.bb
+inherit native
+DEPENDS = "python-native"
+RDEPENDS = ""
+
+do_stage() {
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ ${STAGING_BINDIR}/python setup.py install --prefix=${STAGING_LIBDIR}/.. --install-data=${STAGING_DATADIR} || \
+ oefatal "python setup.py install execution failed."
+}
+
+do_install() {
+ :
+}