aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-soappy_0.11.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-soappy_0.11.6.bb')
-rw-r--r--recipes/python/python-soappy_0.11.6.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/python/python-soappy_0.11.6.bb b/recipes/python/python-soappy_0.11.6.bb
new file mode 100644
index 0000000000..fc7c49912c
--- /dev/null
+++ b/recipes/python/python-soappy_0.11.6.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Python SOAP Bindings"
+SECTION = "devel/python"
+HOMEPAGE = "http://pywebsvcs.sourceforge.net/"
+PRIORITY = "optional"
+LICENSE = "BSD"
+RDEPENDS = "python-xml python-fpconst"
+SRCNAME = "SOAPpy"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pywebsvcs/${SRCNAME}-${PV}.tar.gz \
+ file://fix-future.patch;patch=1 \
+ file://fpconst.py"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_compile_prepend() {
+ install -m 0644 ${WORKDIR}/fpconst.py ${S}/SOAPpy/fpconst.py
+}