aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-edje_svn.bb2
-rw-r--r--recipes/python/python-gst_0.10.10.bb4
-rw-r--r--recipes/python/python-gst_0.10.17.bb4
-rw-r--r--recipes/python/python-imaging_1.1.6.bb2
-rw-r--r--recipes/python/python-ldap_2.3.9.bb2
-rw-r--r--recipes/python/python-m2crypto_0.18.2.bb2
-rw-r--r--recipes/python/python-mysqldb_1.2.1.bb4
-rw-r--r--recipes/python/python-native_2.6.1.bb16
-rw-r--r--recipes/python/python-native_2.6.4.bb18
-rw-r--r--recipes/python/python-numeric_23.7.bb2
-rw-r--r--recipes/python/python-numpy_1.1.1.bb4
-rw-r--r--recipes/python/python-pycairo_1.4.0.bb2
-rw-r--r--recipes/python/python-pycairo_1.8.0.bb2
-rw-r--r--recipes/python/python-pycodes_1.2.bb2
-rw-r--r--recipes/python/python-pycurl_7.18.2.bb2
-rw-r--r--recipes/python/python-pycurl_7.19.0.bb2
-rw-r--r--recipes/python/python-pygobject-native_2.14.2.bb2
-rw-r--r--recipes/python/python-pygobject-native_2.16.0.bb2
-rw-r--r--recipes/python/python-pygobject-native_2.20.0.bb2
-rw-r--r--recipes/python/python-pygobject_2.14.2.bb4
-rw-r--r--recipes/python/python-pygobject_2.16.0.bb2
-rw-r--r--recipes/python/python-pygobject_2.20.0.bb2
-rw-r--r--recipes/python/python-pygtk-1.2_0.6.12.bb2
-rw-r--r--recipes/python/python-pygtk_2.10.4.bb8
-rw-r--r--recipes/python/python-pygtk_2.16.0.bb2
-rw-r--r--recipes/python/python-pyid3lib_0.5.1.bb2
-rw-r--r--recipes/python/python-pylinda_0.6.bb2
-rw-r--r--recipes/python/python-pyode_1.2.0.bb2
-rw-r--r--recipes/python/python-pyqt_4.4.3.bb16
-rw-r--r--recipes/python/python-pyrex_0.9.8.5.bb2
-rw-r--r--recipes/python/python-pyro_3.8.1.bb2
-rw-r--r--recipes/python/python-pysqlite2_2.4.0.bb2
-rw-r--r--recipes/python/python-setuptools_0.6c9.bb2
-rw-r--r--recipes/python/python-soappy_0.11.6.bb2
-rw-r--r--recipes/python/python-traits_3.0.3.bb2
-rw-r--r--recipes/python/python-twisted_2.5.0.bb2
-rw-r--r--recipes/python/python-vorbis_1.4.bb2
-rw-r--r--recipes/python/python_2.6.1.bb26
-rw-r--r--recipes/python/python_2.6.2.bb22
-rw-r--r--recipes/python/python_2.6.4.bb24
40 files changed, 103 insertions, 103 deletions
diff --git a/recipes/python/python-edje_svn.bb b/recipes/python/python-edje_svn.bb
index 2c087cabfd..0e29de183d 100644
--- a/recipes/python/python-edje_svn.bb
+++ b/recipes/python/python-edje_svn.bb
@@ -3,4 +3,4 @@ SRCREV = "${EFL_SRCREV}"
DEPENDS += "edje python-evas"
RDEPENDS += "python-evas"
-SRC_URI += "file://0001-fix-unicode-conversion.patch;patch=1"
+SRC_URI += "file://0001-fix-unicode-conversion.patch;apply=yes"
diff --git a/recipes/python/python-gst_0.10.10.bb b/recipes/python/python-gst_0.10.10.bb
index eb00fb6980..d060b92949 100644
--- a/recipes/python/python-gst_0.10.10.bb
+++ b/recipes/python/python-gst_0.10.10.bb
@@ -6,8 +6,8 @@ PR = "ml4"
SRC_URI = "\
http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.bz2 \
- file://python-path.patch;patch=1 \
- file://import-gobject-instead-of-pygtk.patch;patch=1 \
+ file://python-path.patch;apply=yes \
+ file://import-gobject-instead-of-pygtk.patch;apply=yes \
"
S = "${WORKDIR}/gst-python-${PV}"
diff --git a/recipes/python/python-gst_0.10.17.bb b/recipes/python/python-gst_0.10.17.bb
index 1f82594c71..6aa13f258f 100644
--- a/recipes/python/python-gst_0.10.17.bb
+++ b/recipes/python/python-gst_0.10.17.bb
@@ -7,8 +7,8 @@ PR = "r1"
SRC_URI = "\
http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.bz2 \
- file://python-path.patch;patch=1 \
- file://import-gobject-instead-of-pygtk.patch;patch=1 \
+ file://python-path.patch;apply=yes \
+ file://import-gobject-instead-of-pygtk.patch;apply=yes \
"
S = "${WORKDIR}/gst-python-${PV}"
diff --git a/recipes/python/python-imaging_1.1.6.bb b/recipes/python/python-imaging_1.1.6.bb
index 63e98321e5..4929c7779f 100644
--- a/recipes/python/python-imaging_1.1.6.bb
+++ b/recipes/python/python-imaging_1.1.6.bb
@@ -8,7 +8,7 @@ SRCNAME = "Imaging"
PR = "ml1"
SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
- file://path.patch;patch=1"
+ file://path.patch;apply=yes"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
diff --git a/recipes/python/python-ldap_2.3.9.bb b/recipes/python/python-ldap_2.3.9.bb
index 39ffefd0f1..ea1fd7a6ce 100644
--- a/recipes/python/python-ldap_2.3.9.bb
+++ b/recipes/python/python-ldap_2.3.9.bb
@@ -6,7 +6,7 @@ HOMEPAGE = "http://www.python-ldap.org/"
DEPENDS = "python openldap"
SRC_URI = "http://pypi.python.org/packages/source/p/${PN}/${PN}-${PV}.tar.gz \
- file://setup.cfg.patch;patch=1"
+ file://setup.cfg.patch;apply=yes"
inherit setuptools
diff --git a/recipes/python/python-m2crypto_0.18.2.bb b/recipes/python/python-m2crypto_0.18.2.bb
index 74a212d469..30717abe6f 100644
--- a/recipes/python/python-m2crypto_0.18.2.bb
+++ b/recipes/python/python-m2crypto_0.18.2.bb
@@ -8,7 +8,7 @@ PR = "ml1"
SRC_URI = "\
http://chandlerproject.org/pub/Projects/MeTooCrypto/m2crypto-${PV}.tar.gz \
- file://install.patch;patch=1 \
+ file://install.patch;apply=yes \
"
S = "${WORKDIR}/m2crypto-0.18.2"
diff --git a/recipes/python/python-mysqldb_1.2.1.bb b/recipes/python/python-mysqldb_1.2.1.bb
index 23b16decbe..1722d18579 100644
--- a/recipes/python/python-mysqldb_1.2.1.bb
+++ b/recipes/python/python-mysqldb_1.2.1.bb
@@ -9,8 +9,8 @@ inherit distutils
SRC_URI = "\
${SOURCEFORGE_MIRROR}/mysql-python/MySQL-python-${PV}_p2.tar.gz \
- file://mysqlpath.patch;patch=1 \
- file://site.patch;patch=1 \
+ file://mysqlpath.patch;apply=yes \
+ file://site.patch;apply=yes \
"
S = "${WORKDIR}/${SRCNAME}-${PV}_p2"
diff --git a/recipes/python/python-native_2.6.1.bb b/recipes/python/python-native_2.6.1.bb
index 09e8d5a151..12c622ba10 100644
--- a/recipes/python/python-native_2.6.1.bb
+++ b/recipes/python/python-native_2.6.1.bb
@@ -4,14 +4,14 @@ PR = "${INC_PR}.2"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
- file://00-fix-bindir-libdir-for-cross.patch;patch=1 \
- file://04-default-is-optimized.patch;patch=1 \
- file://05-enable-ctypes-cross-build.patch;patch=1 \
- file://10-distutils-fix-swig-parameter.patch;patch=1 \
- file://11-distutils-never-modify-shebang-line.patch;patch=1 \
- file://12-distutils-prefix-is-inside-staging-area.patch;patch=1 \
- file://debug.patch;patch=1 \
- file://nohostlibs.patch;patch=1 \
+ file://00-fix-bindir-libdir-for-cross.patch;apply=yes \
+ file://04-default-is-optimized.patch;apply=yes \
+ file://05-enable-ctypes-cross-build.patch;apply=yes \
+ file://10-distutils-fix-swig-parameter.patch;apply=yes \
+ file://11-distutils-never-modify-shebang-line.patch;apply=yes \
+ file://12-distutils-prefix-is-inside-staging-area.patch;apply=yes \
+ file://debug.patch;apply=yes \
+ file://nohostlibs.patch;apply=yes \
"
S = "${WORKDIR}/Python-${PV}"
diff --git a/recipes/python/python-native_2.6.4.bb b/recipes/python/python-native_2.6.4.bb
index ffa9a45a91..9c8ce54d6f 100644
--- a/recipes/python/python-native_2.6.4.bb
+++ b/recipes/python/python-native_2.6.4.bb
@@ -4,15 +4,15 @@ PR = "${INC_PR}.3"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2;name=archive \
- file://00-fix-bindir-libdir-for-cross.patch;patch=1 \
- file://04-default-is-optimized.patch;patch=1 \
- file://05-enable-ctypes-cross-build.patch;patch=1 \
- file://06-ctypes-libffi-fix-configure.patch;patch=1 \
- file://10-distutils-fix-swig-parameter.patch;patch=1 \
- file://11-distutils-never-modify-shebang-line.patch;patch=1 \
- file://12-distutils-prefix-is-inside-staging-area.patch;patch=1 \
- file://debug.patch;patch=1 \
- file://nohostlibs.patch;patch=1 \
+ file://00-fix-bindir-libdir-for-cross.patch;apply=yes \
+ file://04-default-is-optimized.patch;apply=yes \
+ file://05-enable-ctypes-cross-build.patch;apply=yes \
+ file://06-ctypes-libffi-fix-configure.patch;apply=yes \
+ file://10-distutils-fix-swig-parameter.patch;apply=yes \
+ file://11-distutils-never-modify-shebang-line.patch;apply=yes \
+ file://12-distutils-prefix-is-inside-staging-area.patch;apply=yes \
+ file://debug.patch;apply=yes \
+ file://nohostlibs.patch;apply=yes \
"
S = "${WORKDIR}/Python-${PV}"
diff --git a/recipes/python/python-numeric_23.7.bb b/recipes/python/python-numeric_23.7.bb
index bddef89788..86c0f14f24 100644
--- a/recipes/python/python-numeric_23.7.bb
+++ b/recipes/python/python-numeric_23.7.bb
@@ -5,7 +5,7 @@ LICENSE = "PSF"
PR = "ml1"
SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/Numeric-${PV}.tar.gz \
- file://no-lapack.patch;patch=1"
+ file://no-lapack.patch;apply=yes"
S = "${WORKDIR}/Numeric-${PV}"
inherit distutils
diff --git a/recipes/python/python-numpy_1.1.1.bb b/recipes/python/python-numpy_1.1.1.bb
index 4efd67a8a6..97a881244d 100644
--- a/recipes/python/python-numpy_1.1.1.bb
+++ b/recipes/python/python-numpy_1.1.1.bb
@@ -5,8 +5,8 @@ LICENSE = "PSF"
PR = "ml0"
SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
- file://unbreak-assumptions.diff;patch=1 \
- file://trycompile.diff;patch=1 \
+ file://unbreak-assumptions.diff;apply=yes \
+ file://trycompile.diff;apply=yes \
file://config.h \
file://numpyconfig.h \
"
diff --git a/recipes/python/python-pycairo_1.4.0.bb b/recipes/python/python-pycairo_1.4.0.bb
index 71faeea070..be2a7cdb9b 100644
--- a/recipes/python/python-pycairo_1.4.0.bb
+++ b/recipes/python/python-pycairo_1.4.0.bb
@@ -6,7 +6,7 @@ DEPENDS = "cairo"
PR = "ml3"
SRC_URI = "http://cairographics.org/releases/pycairo-${PV}.tar.gz \
- file://fix-setup-py.patch;patch=1"
+ file://fix-setup-py.patch;apply=yes"
S = "${WORKDIR}/pycairo-${PV}"
inherit distutils pkgconfig
diff --git a/recipes/python/python-pycairo_1.8.0.bb b/recipes/python/python-pycairo_1.8.0.bb
index 494baefba4..cbdade84ea 100644
--- a/recipes/python/python-pycairo_1.8.0.bb
+++ b/recipes/python/python-pycairo_1.8.0.bb
@@ -9,7 +9,7 @@ PR = "ml0"
DEFAULT_PREFERENCE = "-1"
SRC_URI = "http://cairographics.org/releases/pycairo-${PV}.tar.gz \
- file://fix-setup-py.patch;patch=1"
+ file://fix-setup-py.patch;apply=yes"
S = "${WORKDIR}/pycairo-${PV}"
inherit distutils pkgconfig
diff --git a/recipes/python/python-pycodes_1.2.bb b/recipes/python/python-pycodes_1.2.bb
index 836d928b05..6ebd632086 100644
--- a/recipes/python/python-pycodes_1.2.bb
+++ b/recipes/python/python-pycodes_1.2.bb
@@ -8,7 +8,7 @@ SRCNAME = "pycodes"
PR = "ml1"
SRC_URI = "http://web.mit.edu/~emin/www/source_code/pycodes/pycodes-1-2.tar.gz \
- file://no-docs.patch;patch=1"
+ file://no-docs.patch;apply=yes"
S = "${WORKDIR}/${SRCNAME}"
inherit distutils
diff --git a/recipes/python/python-pycurl_7.18.2.bb b/recipes/python/python-pycurl_7.18.2.bb
index 00bee250f8..c319e6d298 100644
--- a/recipes/python/python-pycurl_7.18.2.bb
+++ b/recipes/python/python-pycurl_7.18.2.bb
@@ -8,7 +8,7 @@ PR = "ml2"
SRC_URI = "\
http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz \
- file://no-static-link.patch;patch=1 \
+ file://no-static-link.patch;apply=yes \
"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/recipes/python/python-pycurl_7.19.0.bb b/recipes/python/python-pycurl_7.19.0.bb
index 36d90d657c..73da6daf63 100644
--- a/recipes/python/python-pycurl_7.19.0.bb
+++ b/recipes/python/python-pycurl_7.19.0.bb
@@ -8,7 +8,7 @@ PR = "ml2"
SRC_URI = "\
http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz;name=archive \
- file://no-static-link.patch;patch=1 \
+ file://no-static-link.patch;apply=yes \
"
S = "${WORKDIR}/${SRCNAME}-${PV}"
SRC_URI[archive.md5sum] = "919d58fe37e69fe87ce4534d8b6a1c7b"
diff --git a/recipes/python/python-pygobject-native_2.14.2.bb b/recipes/python/python-pygobject-native_2.14.2.bb
index 70af95259c..eb58153299 100644
--- a/recipes/python/python-pygobject-native_2.14.2.bb
+++ b/recipes/python/python-pygobject-native_2.14.2.bb
@@ -7,7 +7,7 @@ inherit native
SRC_URI = "\
ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
- file://python-path.patch;patch=1 \
+ file://python-path.patch;apply=yes \
"
do_stage_append() {
diff --git a/recipes/python/python-pygobject-native_2.16.0.bb b/recipes/python/python-pygobject-native_2.16.0.bb
index a1c733334c..5f38091d9b 100644
--- a/recipes/python/python-pygobject-native_2.16.0.bb
+++ b/recipes/python/python-pygobject-native_2.16.0.bb
@@ -9,7 +9,7 @@ inherit native
SRC_URI = "\
ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
-# file://python-path.patch;patch=1 \
+# file://python-path.patch;apply=yes \
"
do_stage_append() {
diff --git a/recipes/python/python-pygobject-native_2.20.0.bb b/recipes/python/python-pygobject-native_2.20.0.bb
index cf36d3ff2d..6e422b5aec 100644
--- a/recipes/python/python-pygobject-native_2.20.0.bb
+++ b/recipes/python/python-pygobject-native_2.20.0.bb
@@ -8,7 +8,7 @@ PARALLEL_MAKE = ""
SRC_URI = "\
ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
-# file://python-path.patch;patch=1 \
+# file://python-path.patch;apply=yes \
"
export GOBJECT_INTROSPECTION_CFLAGS="-pthread -I${STAGING_INCDIR}/gobject-introspection-1.0 -I${STAGING_INCDIR}/glib-2.0 -I${STAGING_LIBDIR}/glib-2.0/include"
diff --git a/recipes/python/python-pygobject_2.14.2.bb b/recipes/python/python-pygobject_2.14.2.bb
index d8d3e331ee..d049037cdb 100644
--- a/recipes/python/python-pygobject_2.14.2.bb
+++ b/recipes/python/python-pygobject_2.14.2.bb
@@ -9,8 +9,8 @@ MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1
SRC_URI = "\
ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
- file://python-path.patch;patch=1 \
- file://generate-constants.patch;patch=1 \
+ file://python-path.patch;apply=yes \
+ file://generate-constants.patch;apply=yes \
"
S = "${WORKDIR}/pygobject-${PV}"
diff --git a/recipes/python/python-pygobject_2.16.0.bb b/recipes/python/python-pygobject_2.16.0.bb
index 94c52038ad..4febf4cb12 100644
--- a/recipes/python/python-pygobject_2.16.0.bb
+++ b/recipes/python/python-pygobject_2.16.0.bb
@@ -9,7 +9,7 @@ MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1
SRC_URI = "\
ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
- file://generate-constants.patch;patch=1 \
+ file://generate-constants.patch;apply=yes \
"
S = "${WORKDIR}/pygobject-${PV}"
diff --git a/recipes/python/python-pygobject_2.20.0.bb b/recipes/python/python-pygobject_2.20.0.bb
index ecad36b388..139e0b0310 100644
--- a/recipes/python/python-pygobject_2.20.0.bb
+++ b/recipes/python/python-pygobject_2.20.0.bb
@@ -10,7 +10,7 @@ MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1
SRC_URI = "\
ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
- file://generate-constants.patch;patch=1 \
+ file://generate-constants.patch;apply=yes \
"
S = "${WORKDIR}/pygobject-${PV}"
diff --git a/recipes/python/python-pygtk-1.2_0.6.12.bb b/recipes/python/python-pygtk-1.2_0.6.12.bb
index e75ad489e0..b58845070c 100644
--- a/recipes/python/python-pygtk-1.2_0.6.12.bb
+++ b/recipes/python/python-pygtk-1.2_0.6.12.bb
@@ -8,7 +8,7 @@ SRCNAME = "pygtk"
PR = "r3"
SRC_URI = "ftp://ftp.gtk.org/pub/gtk/python/v1.2/${SRCNAME}-${PV}.tar.gz \
- file://remove-imlib-et-al.patch;patch=1 \
+ file://remove-imlib-et-al.patch;apply=yes \
file://acinclude.m4"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/recipes/python/python-pygtk_2.10.4.bb b/recipes/python/python-pygtk_2.10.4.bb
index ceea66f5b4..e37646d1bd 100644
--- a/recipes/python/python-pygtk_2.10.4.bb
+++ b/recipes/python/python-pygtk_2.10.4.bb
@@ -10,10 +10,10 @@ PR = "ml12"
MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/${MAJ_VER}/${SRCNAME}-${PV}.tar.bz2 \
- file://fix-gtkunixprint.patch;patch=1 \
- file://prevent_to_get_display_during_import.patch;patch=1 \
- file://nodocs.patch;patch=1 \
- file://gdk_display.patch;patch=1;pnum=0 \
+ file://fix-gtkunixprint.patch;apply=yes \
+ file://prevent_to_get_display_during_import.patch;apply=yes \
+ file://nodocs.patch;apply=yes \
+ file://gdk_display.patch;apply=yes;striplevel=0 \
file://acinclude.m4"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/recipes/python/python-pygtk_2.16.0.bb b/recipes/python/python-pygtk_2.16.0.bb
index 92133c6a54..5522c1a3bc 100644
--- a/recipes/python/python-pygtk_2.16.0.bb
+++ b/recipes/python/python-pygtk_2.16.0.bb
@@ -10,7 +10,7 @@ PR = "r1"
MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/${MAJ_VER}/${SRCNAME}-${PV}.tar.bz2;name=pygtk \
- file://fix-gtkunixprint.patch;patch=1 \
+ file://fix-gtkunixprint.patch;apply=yes \
file://acinclude.m4"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/recipes/python/python-pyid3lib_0.5.1.bb b/recipes/python/python-pyid3lib_0.5.1.bb
index 3b0449a9a6..19d9bf810c 100644
--- a/recipes/python/python-pyid3lib_0.5.1.bb
+++ b/recipes/python/python-pyid3lib_0.5.1.bb
@@ -8,7 +8,7 @@ PR = "r2"
SRC_URI = "\
${SOURCEFORGE_MIRROR}/pyid3lib/${SRCNAME}-${PV}.tar.bz2\
- file://gcc4-fix.patch;patch=1 \
+ file://gcc4-fix.patch;apply=yes \
"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/recipes/python/python-pylinda_0.6.bb b/recipes/python/python-pylinda_0.6.bb
index 3c820c9e61..05e8a05a09 100644
--- a/recipes/python/python-pylinda_0.6.bb
+++ b/recipes/python/python-pylinda_0.6.bb
@@ -7,7 +7,7 @@ SRCNAME = "linda"
PR = "r1"
SRC_URI = "http://www.handhelds.org/~aquadran/distro/latest/sources/linda-${PV}.tar.gz \
- file://honor-datadir.patch;patch=1"
+ file://honor-datadir.patch;apply=yes"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
diff --git a/recipes/python/python-pyode_1.2.0.bb b/recipes/python/python-pyode_1.2.0.bb
index 4ffdb2f71b..702acd79b6 100644
--- a/recipes/python/python-pyode_1.2.0.bb
+++ b/recipes/python/python-pyode_1.2.0.bb
@@ -8,7 +8,7 @@ SRCNAME = "PyODE"
PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/pyode/${SRCNAME}-${PV}.tar.bz2 \
- file://install.patch;patch=1"
+ file://install.patch;apply=yes"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
diff --git a/recipes/python/python-pyqt_4.4.3.bb b/recipes/python/python-pyqt_4.4.3.bb
index b594bcb04a..d2970764a1 100644
--- a/recipes/python/python-pyqt_4.4.3.bb
+++ b/recipes/python/python-pyqt_4.4.3.bb
@@ -13,23 +13,23 @@ PYQT_OE_VERSION = "Qt_4_4_1"
SRC_URI = "\
http://cvs.fedora.redhat.com/repo/pkgs/PyQt4/PyQt-x11-gpl-4.4.3.tar.gz/89e84c36a8520bf8b3a8a2b20e765154/PyQt-x11-gpl-4.4.3.tar.gz \
- file://cross-compile.patch;patch=1 \
- file://01_configure.dpatch;patch=1 \
- file://02_htmllinks.dpatch;patch=1 \
+ file://cross-compile.patch;apply=yes \
+ file://01_configure.dpatch;apply=yes \
+ file://02_htmllinks.dpatch;apply=yes \
\
- file://assistantclient-fix.patch;patch=1 \
+ file://assistantclient-fix.patch;apply=yes \
"
S = "${WORKDIR}/PyQt-x11-gpl-${PV}"
# arm and mips machines need some extra patches
SRC_URI_append_arm = "\
- file://03_qreal.dpatch;patch=1 \
- file://04_qreal_api_fixes-for-4.4.3.dpatch;patch=1"
+ file://03_qreal.dpatch;apply=yes \
+ file://04_qreal_api_fixes-for-4.4.3.dpatch;apply=yes"
SRC_URI_append_mipsel = "\
- file://03_qreal.dpatch;patch=1 \
- file://04_qreal_api_fixes-for-4.4.3.dpatch;patch=1"
+ file://03_qreal.dpatch;apply=yes \
+ file://04_qreal_api_fixes-for-4.4.3.dpatch;apply=yes"
inherit qt4x11 sip distutils-base
diff --git a/recipes/python/python-pyrex_0.9.8.5.bb b/recipes/python/python-pyrex_0.9.8.5.bb
index 18784f3116..2d98c90ce7 100644
--- a/recipes/python/python-pyrex_0.9.8.5.bb
+++ b/recipes/python/python-pyrex_0.9.8.5.bb
@@ -9,7 +9,7 @@ PR = "ml1"
SRC_URI = "\
http://www.cosc.canterbury.ac.nz/greg.ewing/python/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
- file://pyrex-fix-optimized-mode.patch;patch=1 \
+ file://pyrex-fix-optimized-mode.patch;apply=yes \
"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/recipes/python/python-pyro_3.8.1.bb b/recipes/python/python-pyro_3.8.1.bb
index 5b0ef87d11..41d2c1abb9 100644
--- a/recipes/python/python-pyro_3.8.1.bb
+++ b/recipes/python/python-pyro_3.8.1.bb
@@ -10,7 +10,7 @@ PR = "ml0"
SRC_URI = "\
${SOURCEFORGE_MIRROR}/pyro/Pyro-${PV}.tar.gz \
- file://pyro-unattended-install.patch;patch=1;pnum=0 \
+ file://pyro-unattended-install.patch;apply=yes;striplevel=0 \
"
S = "${WORKDIR}/Pyro-${PV}"
diff --git a/recipes/python/python-pysqlite2_2.4.0.bb b/recipes/python/python-pysqlite2_2.4.0.bb
index 407dcc2563..562479b77b 100644
--- a/recipes/python/python-pysqlite2_2.4.0.bb
+++ b/recipes/python/python-pysqlite2_2.4.0.bb
@@ -7,7 +7,7 @@ SRCNAME = "pysqlite"
PR = "ml2"
SRC_URI = "http://initd.org/pub/software/pysqlite/releases/2.4/${PV}/${SRCNAME}-${PV}.tar.gz \
- file://fix-setup.patch;patch=1"
+ file://fix-setup.patch;apply=yes"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
diff --git a/recipes/python/python-setuptools_0.6c9.bb b/recipes/python/python-setuptools_0.6c9.bb
index a962e62c4d..c704205108 100644
--- a/recipes/python/python-setuptools_0.6c9.bb
+++ b/recipes/python/python-setuptools_0.6c9.bb
@@ -9,7 +9,7 @@ PR = "ml0"
SRC_URI = "\
http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\
- file://fix-log-usage.patch;patch=1 \
+ file://fix-log-usage.patch;apply=yes \
"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/recipes/python/python-soappy_0.11.6.bb b/recipes/python/python-soappy_0.11.6.bb
index deb3cd4a66..36677f6f0f 100644
--- a/recipes/python/python-soappy_0.11.6.bb
+++ b/recipes/python/python-soappy_0.11.6.bb
@@ -8,7 +8,7 @@ SRCNAME = "SOAPpy"
PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/pywebsvcs/${SRCNAME}-${PV}.tar.gz \
- file://fix-future.patch;patch=1 \
+ file://fix-future.patch;apply=yes \
file://fpconst.py"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/recipes/python/python-traits_3.0.3.bb b/recipes/python/python-traits_3.0.3.bb
index 044b0d159c..e8c5baa73e 100644
--- a/recipes/python/python-traits_3.0.3.bb
+++ b/recipes/python/python-traits_3.0.3.bb
@@ -8,7 +8,7 @@ inherit setuptools
SRC_URI = "\
http://pypi.python.org/packages/source/T/Traits/Traits-${PV}.tar.gz \
-# file://fix-import-pyface.diff;patch=1 \
+# file://fix-import-pyface.diff;apply=yes \
"
S = "${WORKDIR}/Traits-${PV}"
diff --git a/recipes/python/python-twisted_2.5.0.bb b/recipes/python/python-twisted_2.5.0.bb
index b0d7f791b9..e678bb7e2e 100644
--- a/recipes/python/python-twisted_2.5.0.bb
+++ b/recipes/python/python-twisted_2.5.0.bb
@@ -8,7 +8,7 @@ LICENSE = "LGPL"
PR = "r9"
SRC_URI = "http://tmrc.mit.edu/mirror/twisted/Twisted/2.5/Twisted-${PV}.tar.bz2 \
- file://remove-zope-check.patch;patch=1"
+ file://remove-zope-check.patch;apply=yes"
S = "${WORKDIR}/Twisted-${PV}"
inherit distutils
diff --git a/recipes/python/python-vorbis_1.4.bb b/recipes/python/python-vorbis_1.4.bb
index cc940f0fd6..0d3ecf76f0 100644
--- a/recipes/python/python-vorbis_1.4.bb
+++ b/recipes/python/python-vorbis_1.4.bb
@@ -7,7 +7,7 @@ SRCNAME = "pyvorbis"
PR = "ml0"
SRC_URI = "http://www.andrewchatham.com/pyogg/download/${SRCNAME}-${PV}.tar.gz \
- file://disable-oggcheck.patch;patch=1"
+ file://disable-oggcheck.patch;apply=yes"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
diff --git a/recipes/python/python_2.6.1.bb b/recipes/python/python_2.6.1.bb
index a030f158d7..d7995ca927 100644
--- a/recipes/python/python_2.6.1.bb
+++ b/recipes/python/python_2.6.1.bb
@@ -6,23 +6,23 @@ PR = "${INC_PR}.0"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
- file://00-fix-bindir-libdir-for-cross.patch;patch=1 \
- file://01-use-proper-tools-for-cross-build.patch;patch=1 \
- file://02-remove-test-for-cross.patch;patch=1 \
- file://03-fix-tkinter-detection.patch;patch=1 \
- file://04-default-is-optimized.patch;patch=1 \
- file://05-enable-ctypes-cross-build.patch;patch=1 \
- file://06-libffi-enable-default-mips.patch;patch=1 \
- file://07-export-grammer.patch;patch=1 \
- file://99-ignore-optimization-flag.patch;patch=1 \
+ file://00-fix-bindir-libdir-for-cross.patch;apply=yes \
+ file://01-use-proper-tools-for-cross-build.patch;apply=yes \
+ file://02-remove-test-for-cross.patch;apply=yes \
+ file://03-fix-tkinter-detection.patch;apply=yes \
+ file://04-default-is-optimized.patch;apply=yes \
+ file://05-enable-ctypes-cross-build.patch;apply=yes \
+ file://06-libffi-enable-default-mips.patch;apply=yes \
+ file://07-export-grammer.patch;apply=yes \
+ file://99-ignore-optimization-flag.patch;apply=yes \
\
# not yet pushed forward
# sitecustomize, sitebranding
\
-# file://05-install.patch;patch=1 \
-# file://06-fix-urllib-exception.patch;patch=1 \
-# file://16-bug1179-imageop.patch;patch=1 \
-# file://13-set-wakeup-fix.patch;patch=1 \
+# file://05-install.patch;apply=yes \
+# file://06-fix-urllib-exception.patch;apply=yes \
+# file://16-bug1179-imageop.patch;apply=yes \
+# file://13-set-wakeup-fix.patch;apply=yes \
\
file://sitecustomize.py \
"
diff --git a/recipes/python/python_2.6.2.bb b/recipes/python/python_2.6.2.bb
index dea274b1fc..275ecbc46e 100644
--- a/recipes/python/python_2.6.2.bb
+++ b/recipes/python/python_2.6.2.bb
@@ -7,21 +7,21 @@ PR = "${INC_PR}.0"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
- file://00-fix-bindir-libdir-for-cross.patch;patch=1 \
- file://01-use-proper-tools-for-cross-build.patch;patch=1 \
- file://02-remove-test-for-cross.patch;patch=1 \
- file://03-fix-tkinter-detection.patch;patch=1 \
- file://04-default-is-optimized.patch;patch=1 \
- file://05-enable-ctypes-cross-build.patch;patch=1 \
- file://99-ignore-optimization-flag.patch;patch=1 \
+ file://00-fix-bindir-libdir-for-cross.patch;apply=yes \
+ file://01-use-proper-tools-for-cross-build.patch;apply=yes \
+ file://02-remove-test-for-cross.patch;apply=yes \
+ file://03-fix-tkinter-detection.patch;apply=yes \
+ file://04-default-is-optimized.patch;apply=yes \
+ file://05-enable-ctypes-cross-build.patch;apply=yes \
+ file://99-ignore-optimization-flag.patch;apply=yes \
\
# not yet pushed forward
# sitebranding
\
-# file://05-install.patch;patch=1 \
-# file://06-fix-urllib-exception.patch;patch=1 \
-# file://16-bug1179-imageop.patch;patch=1 \
-# file://13-set-wakeup-fix.patch;patch=1 \
+# file://05-install.patch;apply=yes \
+# file://06-fix-urllib-exception.patch;apply=yes \
+# file://16-bug1179-imageop.patch;apply=yes \
+# file://13-set-wakeup-fix.patch;apply=yes \
\
file://sitecustomize.py \
"
diff --git a/recipes/python/python_2.6.4.bb b/recipes/python/python_2.6.4.bb
index 17891e926b..efd90bdb73 100644
--- a/recipes/python/python_2.6.4.bb
+++ b/recipes/python/python_2.6.4.bb
@@ -7,22 +7,22 @@ PR = "${INC_PR}.1"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2;name=archive \
- file://00-fix-bindir-libdir-for-cross.patch;patch=1 \
- file://01-use-proper-tools-for-cross-build.patch;patch=1 \
- file://02-remove-test-for-cross.patch;patch=1 \
- file://03-fix-tkinter-detection.patch;patch=1 \
- file://04-default-is-optimized.patch;patch=1 \
- file://05-enable-ctypes-cross-build.patch;patch=1 \
- file://06-ctypes-libffi-fix-configure.patch;patch=1 \
- file://99-ignore-optimization-flag.patch;patch=1 \
+ file://00-fix-bindir-libdir-for-cross.patch;apply=yes \
+ file://01-use-proper-tools-for-cross-build.patch;apply=yes \
+ file://02-remove-test-for-cross.patch;apply=yes \
+ file://03-fix-tkinter-detection.patch;apply=yes \
+ file://04-default-is-optimized.patch;apply=yes \
+ file://05-enable-ctypes-cross-build.patch;apply=yes \
+ file://06-ctypes-libffi-fix-configure.patch;apply=yes \
+ file://99-ignore-optimization-flag.patch;apply=yes \
\
# not yet pushed forward
# sitebranding
\
-# file://05-install.patch;patch=1 \
-# file://06-fix-urllib-exception.patch;patch=1 \
-# file://16-bug1179-imageop.patch;patch=1 \
-# file://13-set-wakeup-fix.patch;patch=1 \
+# file://05-install.patch;apply=yes \
+# file://06-fix-urllib-exception.patch;apply=yes \
+# file://16-bug1179-imageop.patch;apply=yes \
+# file://13-set-wakeup-fix.patch;apply=yes \
\
file://sitecustomize.py \
"