aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qi
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/qi')
-rw-r--r--recipes/qi/files/sanitize-makefile.patch2
-rw-r--r--recipes/qi/qi.inc4
2 files changed, 3 insertions, 3 deletions
diff --git a/recipes/qi/files/sanitize-makefile.patch b/recipes/qi/files/sanitize-makefile.patch
index cd1abf3f58..69f34f8cfb 100644
--- a/recipes/qi/files/sanitize-makefile.patch
+++ b/recipes/qi/files/sanitize-makefile.patch
@@ -6,7 +6,7 @@ Index: git/Makefile
include config.mk
--BUILD_DATE := $(shell date)
+-BUILD_DATE := $(shell date --iso-8601=seconds)
-BUILD_HOST := $(shell hostname)
-BUILD_BRANCH := $(shell git branch | grep ^\* | cut -d' ' -f2)
-BUILD_HEAD := $(shell git show --pretty=oneline | head -n1 | cut -d' ' -f1 | cut -b1-16)
diff --git a/recipes/qi/qi.inc b/recipes/qi/qi.inc
index 949a011463..f944390345 100644
--- a/recipes/qi/qi.inc
+++ b/recipes/qi/qi.inc
@@ -16,7 +16,7 @@ do_configure() {
BUILD_HOST=\$(shell hostname)
BUILD_VERSION=${PV}
-BUILD_DATE=\$(shell date)
+BUILD_DATE=\$(shell date --iso-8601=seconds)
# NOTE: The following depends on the fact that only one version of the cross-compiler
# has been built. If it bails out with something like: "| arm-linux-ld: 4.3.3: No such file or directory"
@@ -51,6 +51,6 @@ do_deploy () {
PACKAGE_ARCH = "${MACHINE_ARCH}"
do_deploy[dirs] = "${S}"
-addtask deploy before do_package after do_install
+addtask deploy before do_build after do_package
addtask quilt before do_patch after do_unpack
addtask svnrev before do_patch after do_quilt