aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qpe-games/atomic_1.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/qpe-games/atomic_1.0.1.bb')
-rw-r--r--recipes/qpe-games/atomic_1.0.1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/qpe-games/atomic_1.0.1.bb b/recipes/qpe-games/atomic_1.0.1.bb
new file mode 100644
index 0000000000..33e8aa2dff
--- /dev/null
+++ b/recipes/qpe-games/atomic_1.0.1.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Atomic"
+SECTION = "opie/games"
+PRIORITY = "optional"
+
+LICENSE = "GPL"
+AUTHOR = "Andre Wuest"
+HOMEPAGE = "http://www.linux-solutions.at/projects/zaurus/games-Atomic.html"
+
+
+SRC_URI = "http://handhelds.org/~zecke/oe_packages/atomic_V1.0.1.tar.gz \
+ file://atomic.patch;patch=1"
+
+
+PV = "1.0.1"
+S = "${WORKDIR}/atomic_V${PV}"
+APPNAME = "atomic"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+
+
+
+do_compile_prepend() {
+ oe_runmake -C images
+ oe_runmake -C tools
+ oe_runmake -C levels
+}
+
+do_install () {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${S}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+
+}
+
+inherit opie