aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qpe-games/glider_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/qpe-games/glider_1.0.0.bb')
-rw-r--r--recipes/qpe-games/glider_1.0.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/qpe-games/glider_1.0.0.bb b/recipes/qpe-games/glider_1.0.0.bb
new file mode 100644
index 0000000000..681d5abb43
--- /dev/null
+++ b/recipes/qpe-games/glider_1.0.0.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Glider"
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+AUTHOR = "Robert Ernst"
+HOMEPAGE = "http://www.linux-solutions.at/projects/zaurus/games-Glider.html"
+
+
+SRC_URI = "http://handhelds.org/~zecke/oe_packages/glider_V1.0.0.tar.gz \
+ file://Makefile.patch;patch=1 \
+ file://glider.patch;patch=1"
+
+PV = "1.0.0"
+S = "${WORKDIR}/glider_V${PV}"
+
+APPNAME = "glider"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+do_compile_prepend() {
+ oe_runmake -C images
+}
+
+do_install () {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${S}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+
+}
+
+inherit opie