aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/quake/quake1_0.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/quake/quake1_0.0.1.bb')
-rw-r--r--recipes/quake/quake1_0.0.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/quake/quake1_0.0.1.bb b/recipes/quake/quake1_0.0.1.bb
new file mode 100644
index 0000000000..86210e4621
--- /dev/null
+++ b/recipes/quake/quake1_0.0.1.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Quake 1"
+SECTION = "x11/games"
+PRIORITY = "optional"
+DEPENDS = "libsdl-x11 libsdl-mixer libsdl-net zlib libxau"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "http://mirror1.pdaXrom.org/rc9/src/quake1src.tar.bz2 \
+ http://mirror1.pdaxrom.org/source/src/pak0.tar.gz \
+ file://Makefile.patch;patch=1 \
+ file://cl_parse.c.patch;patch=1 \
+ file://vid_sdl.c.patch;patch=1 \
+ file://host.c.patch;patch=1"
+
+S = "${WORKDIR}/quake1src"
+
+inherit autotools
+
+EXTRA_OEMAKE = "-e"
+
+export CFLAG = "-DHAVE_ZLIB -DNO_DEBUG -finline-function"
+export CXXFLAGS = "-DHAVE_ZLIB -DNO_DEBUG -finline-function"
+export LIBS = "-L${STAGING_LIBDIR} -lz -lm -lX11 -lXext -lXau `${STAGING_BINDIR_CROSS}/sdl-config --libs`"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 quake ${D}${bindir}
+}
+