summaryrefslogtreecommitdiffstats
path: root/recipes/realpath/realpath_1.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/realpath/realpath_1.10.bb')
-rw-r--r--recipes/realpath/realpath_1.10.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/recipes/realpath/realpath_1.10.bb b/recipes/realpath/realpath_1.10.bb
index cd24dabe0b..c6e8d7f8f5 100644
--- a/recipes/realpath/realpath_1.10.bb
+++ b/recipes/realpath/realpath_1.10.bb
@@ -2,6 +2,7 @@ DESCRIPTION = "Return the canonicalized absolute pathname"
SECTION = "utility"
PRIORITY = "optional"
LICENSE = "GPLv2"
+PR = "r1"
SRC_URI = "${DEBIAN_MIRROR}/main/r/realpath/realpath_${PV}.tar.gz;name=realpath \
file://makefile.patch"
@@ -13,5 +14,13 @@ CFLAGS += "-DVERSION=${PV}"
do_install () {
install -d ${D}${bindir}
- install -p -m 0755 ${S}/realpath ${D}${bindir}
+ install -p -m 0755 ${S}/realpath ${D}${bindir}/realpath.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/realpath realpath realpath.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove realpath realpath.${PN}
}