summaryrefslogtreecommitdiffstats
path: root/recipes/realpath/realpath_1.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/realpath/realpath_1.15.bb')
-rw-r--r--recipes/realpath/realpath_1.15.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/recipes/realpath/realpath_1.15.bb b/recipes/realpath/realpath_1.15.bb
index d4001d3c6c..74ffe5a0cd 100644
--- a/recipes/realpath/realpath_1.15.bb
+++ b/recipes/realpath/realpath_1.15.bb
@@ -2,8 +2,8 @@ DESCRIPTION = "Return the canonicalized absolute pathname"
SECTION = "utility"
PRIORITY = "optional"
LICENSE = "GPLv2"
+PR = "r2"
-PR = "r1"
SRC_URI = "${DEBIAN_MIRROR}/main/r/realpath/realpath_${PV}.tar.gz;name=realpath \
file://fix-common-mk.patch \
file://no-po4a.patch \
@@ -15,7 +15,15 @@ TARGET_CC_ARCH += "${LDFLAGS}"
do_install () {
install -d ${D}${bindir}
- install -p -m 0755 ${S}/src/_build/realpath ${D}${bindir}
+ install -p -m 0755 ${S}/src/_build/realpath ${D}${bindir}/realpath.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/realpath realpath realpath.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove realpath realpath.${PN}
}
SRC_URI[realpath.md5sum] = "3351ce6e3d0ce255641c8ca9216a8638"