aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rhythmbox/rhythmbox_0.12.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/rhythmbox/rhythmbox_0.12.1.bb')
-rw-r--r--recipes/rhythmbox/rhythmbox_0.12.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/rhythmbox/rhythmbox_0.12.1.bb b/recipes/rhythmbox/rhythmbox_0.12.1.bb
new file mode 100644
index 0000000000..da2ad63e26
--- /dev/null
+++ b/recipes/rhythmbox/rhythmbox_0.12.1.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Integrated music management application for GNOME"
+LICENSE = "GPL"
+DEPENDS = "dbus-glib-native gtk+ glib-2.0 gnome-doc-utils gnome-media gstreamer gst-plugins-base libgnomeui libglade libnotify libsoup totem-pl-parser"
+# optional dependencies:
+DEPENDS += "avahi gnome-keyring hal libgpod libmusicbrainz nautilus-cd-burner python-pygtk vala"
+#DEPENDS += "brasero mtp"
+
+inherit gnome
+
+# FIXME: Native doc processing with xsltproc using docbook needs additional work:
+do_configure_prepend() {
+ sed -i '/^SUBDIRS/,/^$/s/help//' Makefile.am
+}
+
+EXTRA_OECONF = "--disable-static --disable-scrollkeeper ac_cv_strftime_supports_E_O=yes"
+# FIXME: Verify that in uclibc:
+EXTRA_OECONF_linux-uclibc += "ac_cv_strftime_supports_E_O=no"
+
+EXTRA_OEMAKE = "DBUS_GLIB_BIN=${STAGING_BINDIR_NATIVE} VALAC=${STAGING_BINDIR_NATIVE}/valac"
+
+FILES_${PN}-dbg += "${libdir}/rhythmbox/plugins/.debug ${libdir}/rhythmbox/plugins/*/.debug"
+
+do_install_append () {
+ rm -f ${D}${libdir}/rhythmbox/plugins/*.la
+ rm -f ${D}${libdir}/rhythmbox/plugins/*/*.la
+}