aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rhythmbox/rhythmbox_0.8.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/rhythmbox/rhythmbox_0.8.5.bb')
-rw-r--r--recipes/rhythmbox/rhythmbox_0.8.5.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/rhythmbox/rhythmbox_0.8.5.bb b/recipes/rhythmbox/rhythmbox_0.8.5.bb
new file mode 100644
index 0000000000..8a6f3a8905
--- /dev/null
+++ b/recipes/rhythmbox/rhythmbox_0.8.5.bb
@@ -0,0 +1,29 @@
+LICENSE = "GPL"
+SECTION = "unknown"
+PR = "r4"
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/rhythmbox/0.8/rhythmbox-${PV}.tar.gz \
+ file://ogg.m4 file://vorbis.m4 \
+ file://omfmake.patch;patch=1"
+
+DEPENDS = "gstreamer gst-plugins libgnomeui"
+
+EXTRA_OECONF = "--disable-schemas-install"
+
+FILES_${PN} += " ${libdir}/bonobo/servers ${libdir}/bonobo/*.so ${datadir}/omf ${datadir}/mime-info \
+ ${datadir}/application-registry ${datadir}/gnome-2.0 ${datadir}/idl"
+FILES_${PN}-doc += " ${datadir}/gnome/help"
+FILES_${PN}-dev += " ${libdir}/bonobo/*.la ${libdir}/bonobo/*.a"
+
+RDEPENDS_${PN} = "gst-plugin-gnomevfs gst-plugin-esd gst-plugin-mad gst-plugin-ivorbis"
+
+do_configure_prepend() {
+ mkdir -p ${S}/m4
+ cp ${WORKDIR}/ogg.m4 ${S}/m4/
+ cp ${WORKDIR}/vorbis.m4 ${S}/m4/
+}
+
+inherit autotools gconf
+
+do_compile() {
+ oe_runmake ORBIT_IDL=`which orbit-idl-2`
+}