aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rp-pppoe/rp-pppoe_3.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/rp-pppoe/rp-pppoe_3.5.bb')
-rw-r--r--recipes/rp-pppoe/rp-pppoe_3.5.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/rp-pppoe/rp-pppoe_3.5.bb b/recipes/rp-pppoe/rp-pppoe_3.5.bb
new file mode 100644
index 0000000000..b238962be5
--- /dev/null
+++ b/recipes/rp-pppoe/rp-pppoe_3.5.bb
@@ -0,0 +1,18 @@
+SECTION = "console/network"
+DESCRIPTION="A user-mode PPPoE client and server suite for Linux"
+HOMEPAGE="http://www.roaringpenguin.com/"
+LICENSE="GPLv2"
+
+SRC_URI="http://www.roaringpenguin.com/penguin/pppoe/${P}.tar.gz \
+ file://rp-pppoe-3.5_configure_in_cross.diff;patch=1;pnum=2 \
+ file://rp-pppoe-3.5_libevent_makefile_cross.diff;patch=1;pnum=2 \
+ file://rp-pppoe-3.5_no_strip.diff;patch=1;pnum=2"
+DEPENDS="ppp"
+
+S = "${WORKDIR}/${P}/src"
+
+inherit autotools
+
+do_install() {
+ oe_runmake -C ${S} RPM_INSTALL_ROOT=${D} docdir=${docdir} install
+}