summaryrefslogtreecommitdiffstats
path: root/recipes/sdr
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sdr')
-rw-r--r--recipes/sdr/sdrshell_svn.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/sdr/sdrshell_svn.bb b/recipes/sdr/sdrshell_svn.bb
new file mode 100644
index 0000000000..1641aa5668
--- /dev/null
+++ b/recipes/sdr/sdrshell_svn.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "SDR-Shell is Qt GUI for the sdr-core (DttSP) Software Defined Radio"
+LICENSE = "GPLv2"
+
+DEPENDS = "dttsp"
+
+inherit qmake qt3x11
+
+SRCREV = "57"
+PV = "${SRCREV}"
+
+SRC_URI = "svn://sdr-shell.googlecode.com/svn/branches;module=sdr-shell-v2;proto=http \
+ file://gcc-43-fix.patch;patch=1;pnum=0"
+S = "${WORKDIR}/sdr-shell-v2"
+
+PARALLEL_MAKE = ""
+
+do_configure_prepend() {
+ rm -f ${S}/sdr-shell
+}
+
+do_compile_prepend() {
+ sed -i -e s:OE_QMAKE_LINK:CXX:g ${S}/Makefile
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/sdr-shell ${D}${bindir}
+}
+
+