aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sed
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sed')
-rw-r--r--recipes/sed/sed-4.1/fchmod.patch11
-rw-r--r--recipes/sed/sed-native_4.1.1.bb3
-rw-r--r--recipes/sed/sed-native_4.1.2.bb3
-rw-r--r--recipes/sed/sed_4.0.8.bb8
-rw-r--r--recipes/sed/sed_4.0.9.bb8
-rw-r--r--recipes/sed/sed_4.1.1.bb8
-rw-r--r--recipes/sed/sed_4.1.2.bb26
-rw-r--r--recipes/sed/sed_4.1.bb9
8 files changed, 76 insertions, 0 deletions
diff --git a/recipes/sed/sed-4.1/fchmod.patch b/recipes/sed/sed-4.1/fchmod.patch
new file mode 100644
index 0000000000..b5568b509b
--- /dev/null
+++ b/recipes/sed/sed-4.1/fchmod.patch
@@ -0,0 +1,11 @@
+--- sed-4.1.orig/sed/execute.c
++++ sed-4.1/sed/execute.c
+@@ -670,6 +670,8 @@
+ output_file.fp = ck_mkstemp (&input->out_file_name, tmpdir, "sed");
+ free (tmpdir);
+
++ output_fd = fileno(output_file.fp);
++
+ fstat (fileno (input->fp), &st);
+ #ifdef HAVE_FCHMOD
+ fchmod (output_fd, st.st_mode);
diff --git a/recipes/sed/sed-native_4.1.1.bb b/recipes/sed/sed-native_4.1.1.bb
new file mode 100644
index 0000000000..3bfacd88a3
--- /dev/null
+++ b/recipes/sed/sed-native_4.1.1.bb
@@ -0,0 +1,3 @@
+SECTION = "console/utils"
+require sed_${PV}.bb
+inherit native
diff --git a/recipes/sed/sed-native_4.1.2.bb b/recipes/sed/sed-native_4.1.2.bb
new file mode 100644
index 0000000000..3bfacd88a3
--- /dev/null
+++ b/recipes/sed/sed-native_4.1.2.bb
@@ -0,0 +1,3 @@
+SECTION = "console/utils"
+require sed_${PV}.bb
+inherit native
diff --git a/recipes/sed/sed_4.0.8.bb b/recipes/sed/sed_4.0.8.bb
new file mode 100644
index 0000000000..eac4a9cec3
--- /dev/null
+++ b/recipes/sed/sed_4.0.8.bb
@@ -0,0 +1,8 @@
+LICENSE = "GPL"
+SECTION = "console/utils"
+DESCRIPTION = "sed is a Stream EDitor."
+
+SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz"
+S = "${WORKDIR}/sed-${PV}"
+
+inherit autotools
diff --git a/recipes/sed/sed_4.0.9.bb b/recipes/sed/sed_4.0.9.bb
new file mode 100644
index 0000000000..eac4a9cec3
--- /dev/null
+++ b/recipes/sed/sed_4.0.9.bb
@@ -0,0 +1,8 @@
+LICENSE = "GPL"
+SECTION = "console/utils"
+DESCRIPTION = "sed is a Stream EDitor."
+
+SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz"
+S = "${WORKDIR}/sed-${PV}"
+
+inherit autotools
diff --git a/recipes/sed/sed_4.1.1.bb b/recipes/sed/sed_4.1.1.bb
new file mode 100644
index 0000000000..eac4a9cec3
--- /dev/null
+++ b/recipes/sed/sed_4.1.1.bb
@@ -0,0 +1,8 @@
+LICENSE = "GPL"
+SECTION = "console/utils"
+DESCRIPTION = "sed is a Stream EDitor."
+
+SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz"
+S = "${WORKDIR}/sed-${PV}"
+
+inherit autotools
diff --git a/recipes/sed/sed_4.1.2.bb b/recipes/sed/sed_4.1.2.bb
new file mode 100644
index 0000000000..fe80f3e687
--- /dev/null
+++ b/recipes/sed/sed_4.1.2.bb
@@ -0,0 +1,26 @@
+LICENSE = "GPL"
+SECTION = "console/utils"
+DESCRIPTION = "sed is a Stream EDitor."
+PR = "r1"
+
+SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz"
+S = "${WORKDIR}/sed-${PV}"
+
+inherit autotools
+
+do_install () {
+ autotools_do_install
+ install -d ${D}${base_bindir}
+ mv ${D}${bindir}/sed ${D}${base_bindir}/sed.${PN}
+}
+
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${base_bindir}/sed sed sed.${PN} 100
+}
+
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove sed sed.${PN}
+}
+
diff --git a/recipes/sed/sed_4.1.bb b/recipes/sed/sed_4.1.bb
new file mode 100644
index 0000000000..5f333d1513
--- /dev/null
+++ b/recipes/sed/sed_4.1.bb
@@ -0,0 +1,9 @@
+LICENSE = "GPL"
+SECTION = "console/utils"
+DESCRIPTION = "sed is a Stream EDitor."
+
+SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz \
+ file://fchmod.patch;patch=1"
+S = "${WORKDIR}/sed-${PV}"
+
+inherit autotools