aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/setserial/setserial_2.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/setserial/setserial_2.17.bb')
-rw-r--r--recipes/setserial/setserial_2.17.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/setserial/setserial_2.17.bb b/recipes/setserial/setserial_2.17.bb
new file mode 100644
index 0000000000..0255a9f2b0
--- /dev/null
+++ b/recipes/setserial/setserial_2.17.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "setserial is a program designed to set and/or \
+report the configuration information associated with a serial port"
+HOMEPAGE = "http://setserial.sourceforge.net"
+AUTHOR = "Theodore Ts'o >tytso@mit.edu>"
+SECTION = "console/utils"
+LICENSE = "GPL"
+PR = "r3"
+
+inherit autotools
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/setserial/${PN}-${PV}.tar.gz \
+ file://addflags.patch;patch=1 \
+"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man8
+
+ install -m 0755 ${S}/setserial ${D}${bindir}
+ install -m 0644 ${S}/setserial.8 ${D}${mandir}/man8
+}