aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shfs
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/shfs')
-rw-r--r--recipes/shfs/shfs-modules_0.35.bb28
-rw-r--r--recipes/shfs/shfs-utils_0.35.bb24
2 files changed, 52 insertions, 0 deletions
diff --git a/recipes/shfs/shfs-modules_0.35.bb b/recipes/shfs/shfs-modules_0.35.bb
new file mode 100644
index 0000000000..5151e25aef
--- /dev/null
+++ b/recipes/shfs/shfs-modules_0.35.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "A simple and easy to use Linux kernel (2.4+) module which allows you to mount remote filesystems using plain shell (ssh/rsh) connection. \
+It supports some nice features like number of different caches for access speedup, target system optimisations, etc."
+SECTION = "kernel/modules"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r3"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/shfs/shfs-${PV}.tar.gz"
+S = "${WORKDIR}/shfs-${PV}/shfs/Linux-2.4"
+
+#FIXME depend S on kernel version
+
+inherit module
+
+do_compile() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake KERNEL_SOURCES=${STAGING_KERNEL_DIR} KERNEL=${KERNEL_VERSION} \
+ CC="${KERNEL_CC}" LD="${KERNEL_LD}" LINKER="${KERNEL_LD}" LDFLAGS=-r
+}
+
+do_stage() {
+ install -m 0644 shfs_fs.h shfs.h ${STAGING_INCDIR}/
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/fs/shfs/
+ install -m 0644 shfs.o ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/fs/shfs/shfs.o
+}
diff --git a/recipes/shfs/shfs-utils_0.35.bb b/recipes/shfs/shfs-utils_0.35.bb
new file mode 100644
index 0000000000..8c7e05c0e5
--- /dev/null
+++ b/recipes/shfs/shfs-utils_0.35.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "A simple and easy to use Linux kernel (2.4+) module which allows you to mount remote filesystems using plain shell (ssh/rsh) connection. \
+It supports some nice features like number of different caches for access speedup, target system optimisations, etc."
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "shfs-modules (${PV})"
+DEPENDS = "virtual/kernel"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/shfs/shfs-${PV}.tar.gz"
+S = "${WORKDIR}/shfs-${PV}/shfsmount"
+
+KERNEL_VERSION = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')}"
+KV = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')[:3]}"
+
+CFLAGS_append=' -DVERSION=\\"${KERNEL_VERSION}\\" -DSHFS_VERSION=\\"${PV}\\" -I../shfs/Linux-${KV}'
+
+do_compile() {
+ oe_runmake LINKER="${CC}"
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 shfsmount shfsumount ${D}${bindir}
+}