aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr/e-wm-theme-illume-gry_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/shr/e-wm-theme-illume-gry_git.bb')
-rw-r--r--recipes/shr/e-wm-theme-illume-gry_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/shr/e-wm-theme-illume-gry_git.bb b/recipes/shr/e-wm-theme-illume-gry_git.bb
new file mode 100644
index 0000000000..e993cb6e37
--- /dev/null
+++ b/recipes/shr/e-wm-theme-illume-gry_git.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "gry* illume theme - a fast, shiny illume theme"
+SECTION = "e/utils"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+DEPENDS = "edje-native"
+RRECOMMENDS = "elementary-theme-gry"
+LICENCE = "unknown"
+
+PV = "0.3-${EFL_SRCREV}+gitr${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/e-wm/${PN}"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/. -fd ${S}/. ${S}/gry.edc -o ${S}/gry.edj
+}
+
+do_install() {
+ install -d ${D}${datadir}/enlightenment/data/themes/
+ install -m 0644 ${S}/gry.edj ${D}${datadir}/enlightenment/data/themes/
+}
+
+FILES_${PN} = "${datadir}/enlightenment/data/themes/"