summaryrefslogtreecommitdiffstats
path: root/recipes/shr
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/shr')
-rw-r--r--recipes/shr/frameworkd-config-shr_git.bb2
-rw-r--r--recipes/shr/shr-splash-theme-logo_git.bb11
-rw-r--r--recipes/shr/shr-splash-theme.inc12
3 files changed, 18 insertions, 7 deletions
diff --git a/recipes/shr/frameworkd-config-shr_git.bb b/recipes/shr/frameworkd-config-shr_git.bb
index bc7284f217..8b9a3862fd 100644
--- a/recipes/shr/frameworkd-config-shr_git.bb
+++ b/recipes/shr/frameworkd-config-shr_git.bb
@@ -6,7 +6,7 @@ DEPENDS = "python-cython-native python-pyrex-native"
LICENSE = "GPL"
SRCREV_pn-frameworkd-config-shr_FSO_REV ?= "cfc0a5c3def2dc2556c86f3dad182181124de006"
-SRCREV_pn-frameworkd-config-shr_SHR_REV ?= "4bc1a7e7a59ede2a750ee7d02729fa9c535641d9"
+SRCREV_pn-frameworkd-config-shr_SHR_REV ?= "41871d1c920b5db024d9a7d54d03fdab0494b8a2"
SRCREV_FORMAT = "FSO_REV-SHR_REV"
PV = "0.9.5.9+gitr${SRCPV}"
diff --git a/recipes/shr/shr-splash-theme-logo_git.bb b/recipes/shr/shr-splash-theme-logo_git.bb
index 6d838b435c..08848510ae 100644
--- a/recipes/shr/shr-splash-theme-logo_git.bb
+++ b/recipes/shr/shr-splash-theme-logo_git.bb
@@ -1,13 +1,20 @@
DESCRIPTION = "SHR splash screen - SHR logo theme"
SECTION = "x11/data"
LICENSE = "MIT BSD"
-SRCREV = "1cc80e26a4558dfc2268b349d9a1f468e515bcfb"
+SRCREV = "baad098dc8c8058a712a6d98a69b5558ccc54973"
PV = "0.1+gitr${SRCPV}"
-PR = "r1"
+PR = "r3"
SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
S = "${WORKDIR}/git/shr-splash/${PN}"
+SS = "${S}"
+SS_append_nokia900 = "/nokia900"
+SS_append_om-gta01 = "/om-gta01"
+SS_append_om-gta02 = "/om-gta02"
+SS_append_htcdream = "/htcdream"
+SS_append_palmpre = "/palmpre"
+
ALTERNATIVE_PRIORITY = 3
require shr-splash-theme.inc
diff --git a/recipes/shr/shr-splash-theme.inc b/recipes/shr/shr-splash-theme.inc
index 63e275fbfb..f51899155c 100644
--- a/recipes/shr/shr-splash-theme.inc
+++ b/recipes/shr/shr-splash-theme.inc
@@ -4,19 +4,23 @@ inherit update-alternatives
FILES_${PN} = "${datadir}/shr-splash/themes/${PN}"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
ALTERNATIVE_NAME = "shr-splash-theme"
ALTERNATIVE_LINK = "${datadir}/shr-splash/theme"
ALTERNATIVE_PATH = "${datadir}/shr-splash/themes/${PN}"
ALTERNATIVE_PRIORITY ?= 1
+SS ?= "${S}"
+
do_install() {
install -d ${D}${datadir}/shr-splash/themes/${PN}
- install -m 0644 ${S}/xsplash-vga.ppm ${D}${datadir}/shr-splash/themes/${PN}/xsplash-vga.ppm
- install -m 0644 ${S}/boot.fbz ${D}${datadir}/shr-splash/themes/${PN}/boot.fbz
- install -m 0644 ${S}/shutdown.fbz ${D}${datadir}/shr-splash/themes/${PN}/shutdown.fbz
+ install -m 0644 ${SS}/xsplash-vga.ppm ${D}${datadir}/shr-splash/themes/${PN}/xsplash-vga.ppm
+ install -m 0644 ${SS}/boot.fbz ${D}${datadir}/shr-splash/themes/${PN}/boot.fbz
+ install -m 0644 ${SS}/shutdown.fbz ${D}${datadir}/shr-splash/themes/${PN}/shutdown.fbz
install -m 0644 ${S}/name ${D}${datadir}/shr-splash/themes/${PN}/name
install -m 0644 ${S}/author ${D}${datadir}/shr-splash/themes/${PN}/author
- install -m 0644 ${S}/preview.png ${D}${datadir}/shr-splash/themes/${PN}/preview.png
+ install -m 0644 ${SS}/preview.png ${D}${datadir}/shr-splash/themes/${PN}/preview.png
}