aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sidplayer/sidplayer_1.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sidplayer/sidplayer_1.5.0.bb')
-rw-r--r--recipes/sidplayer/sidplayer_1.5.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/sidplayer/sidplayer_1.5.0.bb b/recipes/sidplayer/sidplayer_1.5.0.bb
new file mode 100644
index 0000000000..9929aa8c9f
--- /dev/null
+++ b/recipes/sidplayer/sidplayer_1.5.0.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "A SID Player for the Qt/Embedded based Palmtop Environments"
+SECTION = "opie/multimedia"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://sidplayer.sourceforge.net/"
+DEPENDS = "libsidplay"
+PR = "r1"
+
+SRC_URI = "http://sidplayer.sourceforge.net/sidplayer.tar.gz \
+ file://use-external-libsidplay.patch;patch=1 \
+ file://gcc3.patch;patch=1 \
+ file://gcc34.patch;patch=1"
+S = "${WORKDIR}/sidplayer"
+
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${STAGING_INCDIR}/sidplay"
+
+inherit palmtop
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics
+ cp -pPR ../apps ../bin ../pics ${D}${palmtopdir}/
+}