aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/simpad-utilities/genboot-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/simpad-utilities/genboot-native.bb')
-rw-r--r--recipes/simpad-utilities/genboot-native.bb23
1 files changed, 12 insertions, 11 deletions
diff --git a/recipes/simpad-utilities/genboot-native.bb b/recipes/simpad-utilities/genboot-native.bb
index 47b9b34640..b7bfe01f0a 100644
--- a/recipes/simpad-utilities/genboot-native.bb
+++ b/recipes/simpad-utilities/genboot-native.bb
@@ -1,20 +1,21 @@
-SECTION = "console/utils"
-PR = "r1"
DESCRIPTION = "Console utility for generating a SIMpad boot image for the proprietary SIEMENS Switzerland bootloader"
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/genboot"
-SRC_URI = "file://gen_boot.c file://arnold_boot.h file://simpad-make-flashimg"
+SECTION = "console/utils"
LICENSE = "GPL"
-
DEPENDS = "pad-native"
+PR = "r2"
+
+SRC_URI = "file://gen_boot.c file://arnold_boot.h file://simpad-make-flashimg"
inherit native
do_compile() {
- cp ${WORKDIR}/*.h ${WORKDIR}/*.c .
- ${CC} -I. -o genboot gen_boot.c
+ cp ${WORKDIR}/*.h ${WORKDIR}/*.c .
+ ${CC} -I. -o genboot gen_boot.c
}
-
-do_stage() {
- install -m 0755 genboot ${STAGING_BINDIR}/
- install -m 0755 ${WORKDIR}/simpad-make-flashimg ${STAGING_BINDIR}/
+do_install() {
+ install -d ${D}${bindir}/
+ install -m 0755 genboot ${D}${bindir}/
+ install -m 0755 ${WORKDIR}/simpad-make-flashimg ${D}${bindir}/
}
+
+NATIVE_INSTALL_WORKS = "1"