aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sip/sip-native_4.7.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sip/sip-native_4.7.3.bb')
-rw-r--r--recipes/sip/sip-native_4.7.3.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/sip/sip-native_4.7.3.bb b/recipes/sip/sip-native_4.7.3.bb
new file mode 100644
index 0000000000..b47a3a7539
--- /dev/null
+++ b/recipes/sip/sip-native_4.7.3.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "SIP is a C++/Python Wrapper Generator"
+SECTION = "devel"
+HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip"
+AUTHOR = "Phil Thompson"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "http://www.riverbankcomputing.com/Downloads/sip4/sip-${PV}.tar.gz"
+S = "${WORKDIR}/sip-${PV}/sipgen"
+
+inherit qt4x11 native
+
+EXTRA_QMAKEVARS_POST += "DESTDIR=${S} CONFIG=console"
+
+do_configure_prepend() {
+ cat sipgen.sbf | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, > sipgen.pro
+}
+
+do_stage() {
+ install -m 0755 sip ${STAGING_BINDIR_NATIVE}/sip
+ cd ${WORKDIR}/sip-${PV} && python configure.py
+ install -d ${STAGING_PYDIR}/site-packages
+ install -m 0755 sip*.py ${STAGING_PYDIR}/site-packages
+}
+