aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/slugtool/slugtool.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/slugtool/slugtool.bb')
-rw-r--r--recipes/slugtool/slugtool.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/slugtool/slugtool.bb b/recipes/slugtool/slugtool.bb
new file mode 100644
index 0000000000..fb7497931f
--- /dev/null
+++ b/recipes/slugtool/slugtool.bb
@@ -0,0 +1,17 @@
+SECTION = "unknown"
+DESCRIPTION = "Slugtool is a small app to disassemble and reassemble \
+flash images for the Linksys NSLU2 device."
+PR = "r1"
+LICENSE = "GPL"
+SRC_URI = "http://www.lantz.com/filemgmt_data/files/slugtool.tar.gz \
+ file://redboot_typo.patch;patch=1"
+S = "${WORKDIR}"
+
+do_compile () {
+ ${CC} ${CFLAGS} ${LDFLAGS} slugtool.c -o slugtool
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 slugtool ${D}${bindir}/
+}