summaryrefslogtreecommitdiffstats
path: root/recipes/smpeg/smpeg-0.4.5+svnr387/add-disable-rpath.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/smpeg/smpeg-0.4.5+svnr387/add-disable-rpath.patch')
-rw-r--r--recipes/smpeg/smpeg-0.4.5+svnr387/add-disable-rpath.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes/smpeg/smpeg-0.4.5+svnr387/add-disable-rpath.patch b/recipes/smpeg/smpeg-0.4.5+svnr387/add-disable-rpath.patch
new file mode 100644
index 0000000000..e1de0ea1e8
--- /dev/null
+++ b/recipes/smpeg/smpeg-0.4.5+svnr387/add-disable-rpath.patch
@@ -0,0 +1,47 @@
+Upstream: http://icculus.org/pipermail/smpeg/2010-November/000183.html
+
+Add --disable-rpath to fix build in OE.
+
+--- trunk/configure.in.orig 2010-11-07 09:00:19.000000000 -0500
++++ trunk/configure.in 2010-11-10 13:02:06.000000000 -0500
+@@ -84,19 +84,27 @@
+ ;;
+ esac
+
+-# Set runtime shared library paths as needed
+-
+-case "$target" in
+- *-*-linux*)
+- SMPEG_RLD_FLAGS="-Wl,-rpath,\${exec_prefix}/lib"
+- ;;
+- *-*-freebsd*)
+- SMPEG_RLD_FLAGS="-Wl,-rpath,\${exec_prefix}/lib"
+- ;;
+- *-*-solaris*)
+- SMPEG_RLD_FLAGS="-R\${exec_prefix}/lib"
+- ;;
+-esac
++dnl Set runtime shared library paths as needed
++AC_ARG_ENABLE(rpath,
++ AC_HELP_STRING([--enable-rpath],
++ [use an rpath when linking SDL [[default=yes]]]),,
++ enable_rpath=yes)
++
++if test "x$enable_rpath" = "xyes"; then
++ case "$target" in
++ *-*-linux*)
++ SMPEG_RLD_FLAGS="-Wl,-rpath,\${exec_prefix}/lib"
++ ;;
++ *-*-freebsd*)
++ SMPEG_RLD_FLAGS="-Wl,-rpath,\${exec_prefix}/lib"
++ ;;
++ *-*-solaris*)
++ SMPEG_RLD_FLAGS="-R\${exec_prefix}/lib"
++ ;;
++ esac
++else
++ SMPEG_RLD_FLAGS=""
++fi
+
+ AC_SUBST(SMPEG_RLD_FLAGS)
+