aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/smpeg
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/smpeg')
-rw-r--r--recipes/smpeg/smpeg/as-fix.patch18
-rw-r--r--recipes/smpeg/smpeg_svn.bb40
2 files changed, 15 insertions, 43 deletions
diff --git a/recipes/smpeg/smpeg/as-fix.patch b/recipes/smpeg/smpeg/as-fix.patch
deleted file mode 100644
index 1a747018e5..0000000000
--- a/recipes/smpeg/smpeg/as-fix.patch
+++ /dev/null
@@ -1,18 +0,0 @@
----
- configure.in | 1 +
- 1 file changed, 1 insertion(+)
-
---- trunk.orig/configure.in
-+++ trunk/configure.in
-@@ -54,10 +54,11 @@ AC_PROG_MAKE_SET
- AC_PROG_CC
- AC_PROG_CXX
- AC_LIBTOOL_WIN32_DLL
- AM_PROG_LIBTOOL
- AC_PROG_INSTALL
-+AM_PROG_AS
-
- dnl Ugh.
- AS="$CC"
- CCAS="$CC"
- AC_SUBST(AS)
diff --git a/recipes/smpeg/smpeg_svn.bb b/recipes/smpeg/smpeg_svn.bb
index 343e0bd2eb..7883463df4 100644
--- a/recipes/smpeg/smpeg_svn.bb
+++ b/recipes/smpeg/smpeg_svn.bb
@@ -6,41 +6,31 @@ DEPENDS = "virtual/libsdl"
PROVIDES = "smpeg"
PV = "0.4.5+svnr${SRCPV}"
PE = "1"
-SRCREV = "370"
+SRCREV = "387"
-SRC_URI = "svn://svn.icculus.org/smpeg/;module=trunk \
- file://m4.patch;patch=1 \
- file://as-fix.patch;patch=1"
+SRC_URI = "svn://svn.icculus.org/smpeg/;module=trunk"
S = "${WORKDIR}/trunk"
-inherit autotools
+inherit autotools binconfig
-export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
-
-CFLAGS_append = " -I${STAGING_INCDIR}/SDL"
EXTRA_OECONF = "--disable-gtktest --disable-opengl-player --without-x \
--without-gtk --disable-gtk-player"
do_configure_prepend () {
touch NEWS AUTHORS ChangeLog
- rm -f acinclude.m4
-}
-
-do_stage() {
- oe_libinstall -so -C .libs libsmpeg-0.4 ${STAGING_LIBDIR}
- ln -sf libsmpeg-0.4.so ${STAGING_LIBDIR}/libsmpeg.so
-
- for f in "*.h"
- do
- install -m 0644 ${f} ${STAGING_INCDIR}/SDL
- done
-
- cat smpeg-config | sed -e "s,-I/usr/include/SDL,-I${STAGING_INCDIR}/SDL," \
- | sed -e "s,-I/usr/include/smpeg, ," \
- | sed -e "s,libdirs ,mickey_is_cool ," \
- | sed -e "s,-lSDL ,-lSDL-1.2 , "> ${STAGING_BINDIR_CROSS}/smpeg-config
- chmod a+rx ${STAGING_BINDIR_CROSS}/smpeg-config
+ # drop all .m4 which are available in staging
+ rm -f acinclude/gtk-2.0.m4 \
+ acinclude/libtool.m4 \
+ acinclude/ltdl.m4 \
+ acinclude/ltoptions.m4 \
+ acinclude/ltsugar.m4 \
+ acinclude/ltversion.m4 \
+ acinclude/lt~obsolete.m4 \
+ acinclude/pkg.m4 \
+ acinclude/sdl.m4 \
+ aclocal.m4 \
+ acinclude.m4
}
PACKAGES =+ "plaympeg "