aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/snes9x/snes9x-sdl_1.39.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/snes9x/snes9x-sdl_1.39.bb')
-rw-r--r--recipes/snes9x/snes9x-sdl_1.39.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/snes9x/snes9x-sdl_1.39.bb b/recipes/snes9x/snes9x-sdl_1.39.bb
new file mode 100644
index 0000000000..ea4eb44666
--- /dev/null
+++ b/recipes/snes9x/snes9x-sdl_1.39.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Super Nintendo Emulator based on SDL"
+SECTION = "games"
+PRIORITY = "optional"
+DEPENDS = "virtual/libsdl zlib"
+LICENSE = "snes9x"
+PR = "r3"
+
+SRC_URI = "http://www.vanille.de/mirror/snes9x-sdl-${PV}.tar.bz2 \
+ file://compile.patch;patch=1 \
+ file://gcc-4.1.patch;patch=1"
+S = "${WORKDIR}/snes9x-sdl-${PV}"
+
+do_compile() {
+ oe_runmake CC="${CC}" CCC="${CXX} -fno-rtti -fno-exceptions" \
+ INCLUDES="-I${STAGING_INCDIR} `sdl-config --cflags`" \
+ LDLIBS="`sdl-config --libs`"
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 snes9x ${D}${bindir}/snes9x
+}
+
+FILES_${PN} = "${bindir}/snes9x"