aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/snes9x/snes9x_1.43-WIP1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/snes9x/snes9x_1.43-WIP1.bb')
-rw-r--r--recipes/snes9x/snes9x_1.43-WIP1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/snes9x/snes9x_1.43-WIP1.bb b/recipes/snes9x/snes9x_1.43-WIP1.bb
new file mode 100644
index 0000000000..0b746795f2
--- /dev/null
+++ b/recipes/snes9x/snes9x_1.43-WIP1.bb
@@ -0,0 +1,27 @@
+SECTION = "x11/games"
+PR = "r3"
+LICENSE = "snes9x"
+DEPENDS = "libxxf86dga libxxf86vm"
+DEPENDS_append_i686 = " nasm-native"
+RDEPENDS_epia = "kernel-module-joydev"
+
+SRC_URI = "http://www.lysator.liu.se/snes9x/1.43-WIP1/snes9x-1.43-WIP1-src.tar.gz \
+ file://makefile.patch;patch=1;pnum=2 \
+ file://private.patch;patch=1;pnum=0 \
+ file://64bit.patch;patch=1"
+
+S = "${WORKDIR}/snes9x-1.43-dev-src/snes9x"
+
+inherit autotools
+
+export OECFLAGS="${CFLAGS}"
+export OELDFLAGS="${LDFLAGS}"
+
+do_configure() {
+ oe_runconf
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install snes9x ${D}${bindir}
+}