aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sox/sox_12.17.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sox/sox_12.17.5.bb')
-rw-r--r--recipes/sox/sox_12.17.5.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/sox/sox_12.17.5.bb b/recipes/sox/sox_12.17.5.bb
new file mode 100644
index 0000000000..a3cd84e726
--- /dev/null
+++ b/recipes/sox/sox_12.17.5.bb
@@ -0,0 +1,20 @@
+# sox OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="SoX is the Swiss Army knife of sound processing tools. \
+It converts audio files among various standard audio file formats \
+and can apply different effects and filters to the audio data."
+LICENSE="GPL"
+HOMEPAGE="http://sox.sourceforge.net"
+
+SRC_URI="${SOURCEFORGE_MIRROR}/sox/sox-${PV}.tar.gz; \
+ file://uclibc-fixes.patch;patch=1"
+
+inherit autotools
+
+do_install() {
+ make bindir="${D}${bindir}" libdir="${D}${libdir}" mandir="${D}/${mandir}" includedir="${D}${includedir}" install
+ rm ${D}${bindir}/rec
+ ln -s /usr/bin/play ${D}${bindir}/rec
+}