aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sparse
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sparse')
-rw-r--r--recipes/sparse/files/compile.patch16
-rw-r--r--recipes/sparse/files/vars.patch42
-rw-r--r--recipes/sparse/sparse_snapshot.bb25
3 files changed, 83 insertions, 0 deletions
diff --git a/recipes/sparse/files/compile.patch b/recipes/sparse/files/compile.patch
new file mode 100644
index 0000000000..f19d521335
--- /dev/null
+++ b/recipes/sparse/files/compile.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- sparse-bk/expression.c~compile 2004-09-13 17:42:22.642639000 -0400
++++ sparse-bk/expression.c 2004-09-13 17:44:59.147847520 -0400
+@@ -8,7 +8,7 @@
+ *
+ * This is the expression parsing part of parsing C.
+ */
+-#define _ISOC99_SOURCE
++//#define _ISOC99_SOURCE
+ #include <stdarg.h>
+ #include <stdlib.h>
+ #include <stdio.h>
diff --git a/recipes/sparse/files/vars.patch b/recipes/sparse/files/vars.patch
new file mode 100644
index 0000000000..353df2ad0b
--- /dev/null
+++ b/recipes/sparse/files/vars.patch
@@ -0,0 +1,42 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- sparse-bk/Makefile~vars 2004-09-13 17:45:43.304134000 -0400
++++ sparse-bk/Makefile 2004-09-13 17:46:04.980839384 -0400
+@@ -1,4 +1,5 @@
+ CC=gcc
++CCLD=gcc
+ CFLAGS=-O -g -Wall
+ LDFLAGS=-g
+ AR=ar
+@@ -26,22 +27,22 @@
+ if test $< -nt $(PREFIX)/bin/sparse ; then install -v $< $(PREFIX)/bin/sparse ; fi
+
+ test-lexing: test-lexing.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ test-parsing: test-parsing.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ test-linearize: test-linearize.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ compile: compile.o compile-i386.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< compile-i386.o $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< compile-i386.o $(LIBS)
+
+ obfuscate: obfuscate.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ check: check.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ $(LIB_FILE): $(LIB_OBJS)
+ $(AR) rcs $(LIB_FILE) $(LIB_OBJS)
diff --git a/recipes/sparse/sparse_snapshot.bb b/recipes/sparse/sparse_snapshot.bb
new file mode 100644
index 0000000000..6a913d69ec
--- /dev/null
+++ b/recipes/sparse/sparse_snapshot.bb
@@ -0,0 +1,25 @@
+SECTION = "devel"
+def get_snapshot_date(d):
+ import bb
+ srcdate = bb.data.getVar('SRCDATE', d, 1)
+ if not srcdate:
+ return ""
+ y = srcdate[0:4]
+ m = srcdate[4:6]
+ d = srcdate[6:8]
+ return "%s-%s-%s" % (y, m, d)
+
+DESCRIPTION = "Sparse is a semantic parser of source files: it's neither a \
+compiler (although it could be used as a front-end for one) nor is it a \
+preprocessor (although it contains as a part of it a preprocessing phase)."
+PV = "0.0+${SRCDATE}"
+LICENSE = "OSL"
+SRC_URI = "http://www.codemonkey.org.uk/projects/git-snapshots/sparse/sparse-${@get_snapshot_date(d)}.tar.gz \
+ file://compile.patch;patch=1 \
+ file://vars.patch;patch=1"
+S = "${WORKDIR}/sparse-bk"
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 check ${D}${bindir}/sparse
+}