aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch')
-rw-r--r--recipes/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch b/recipes/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch
new file mode 100644
index 0000000000..e936f81c72
--- /dev/null
+++ b/recipes/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch
@@ -0,0 +1,30 @@
+diff -bur sqlite-2.8.17~orig/main.mk sqlite-2.8.17/main.mk
+--- sqlite-2.8.17~orig/main.mk 2005-04-23 17:43:23.000000000 -0500
++++ sqlite-2.8.17/main.mk 2006-02-13 03:31:03.000000000 -0600
+@@ -139,7 +139,7 @@
+ # This is the default Makefile target. The objects listed here
+ # are what get build when you type just "make" with no arguments.
+ #
+-all: sqlite.h config.h libsqlite.a sqlite$(EXE)
++all: sqlite.h config.h libsqlite.so sqlite$(EXE)
+
+ # Generate the file "last_change" which contains the date of change
+ # of the most recently modified source code file
+@@ -148,13 +148,12 @@
+ cat $(SRC) | grep '$$Id: ' | sort +4 | tail -1 \
+ | awk '{print $$5,$$6}' >last_change
+
+-libsqlite.a: $(LIBOBJ)
+- $(AR) libsqlite.a $(LIBOBJ)
+- $(RANLIB) libsqlite.a
++libsqlite.so: $(LIBOBJ)
++ $(CC) -shared -o libsqlite.so -Wl,-soname,libsqlite.so.0 $(LIBOBJ)
+
+-sqlite$(EXE): $(TOP)/src/shell.c libsqlite.a sqlite.h
++sqlite$(EXE): $(TOP)/src/shell.c libsqlite.so sqlite.h
+ $(TCCX) $(READLINE_FLAGS) -o sqlite$(EXE) $(TOP)/src/shell.c \
+- libsqlite.a $(LIBREADLINE) $(THREADLIB)
++ -lsqlite $(LIBREADLINE) $(THREADLIB)
+
+ sqlite_analyzer$(EXE): $(TOP)/src/tclsqlite.c libsqlite.a $(TESTSRC) \
+ $(TOP)/tool/spaceanal.tcl