aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/squid/squid-3.1.4
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/squid/squid-3.1.4')
-rw-r--r--recipes/squid/squid-3.1.4/fix-ltdl-usage.patch22
-rw-r--r--recipes/squid/squid-3.1.4/fix-runs-in-configure.patch80
-rw-r--r--recipes/squid/squid-3.1.4/squidv3-build-cf_gen.patch33
3 files changed, 135 insertions, 0 deletions
diff --git a/recipes/squid/squid-3.1.4/fix-ltdl-usage.patch b/recipes/squid/squid-3.1.4/fix-ltdl-usage.patch
new file mode 100644
index 0000000000..ea8536dc76
--- /dev/null
+++ b/recipes/squid/squid-3.1.4/fix-ltdl-usage.patch
@@ -0,0 +1,22 @@
+Index: squid-3.1.4/configure.in
+===================================================================
+--- squid-3.1.4.orig/configure.in 2010-07-07 12:20:47.000000000 +0400
++++ squid-3.1.4/configure.in 2010-07-07 12:23:17.000000000 +0400
+@@ -79,7 +79,8 @@
+ top_build_prefix=${ac_top_build_prefix}
+ AC_SUBST(top_build_prefix)
+
+- AC_LIBLTDL_CONVENIENCE
++ LT_CONFIG_LTDL_DIR(libltdl)
++ LTDL_INIT(convenience)
+ fi
+ AC_PROG_LIBTOOL
+ AC_LTDL_DLLIB
+@@ -3965,6 +3966,6 @@
+ AC_CONFIG_SUBDIRS(lib/libTrie)
+
+ # must configure libltdl subdir unconditionally for "make distcheck" to work
+-AC_CONFIG_SUBDIRS(libltdl)
++# AC_CONFIG_SUBDIRS(libltdl)
+
+ AC_OUTPUT
diff --git a/recipes/squid/squid-3.1.4/fix-runs-in-configure.patch b/recipes/squid/squid-3.1.4/fix-runs-in-configure.patch
new file mode 100644
index 0000000000..db4f7c0e03
--- /dev/null
+++ b/recipes/squid/squid-3.1.4/fix-runs-in-configure.patch
@@ -0,0 +1,80 @@
+Index: squid-3.1.4/configure.in
+===================================================================
+--- squid-3.1.4.orig/configure.in 2010-07-06 16:09:45.000000000 +0400
++++ squid-3.1.4/configure.in 2010-07-06 16:09:45.000000000 +0400
+@@ -365,10 +365,6 @@
+ fi
+ ])
+
+-dnl Nasty hack to get autoconf 2.64 on Linux to run.
+-dnl all other uses of RUN_IFELSE are wrapped inside CACHE_CHECK which breaks on 2.64
+-AC_RUN_IFELSE([AC_LANG_SOURCE([[ int main(int argc, char **argv) { return 0; } ]])],[],[],[])
+-
+ dnl This is a developer only option.. developers know how to set defines
+ dnl
+ dnl AC_ARG_ENABLE(xmalloc-debug,
+@@ -2680,7 +2676,7 @@
+ ;;
+ esac
+ AC_CACHE_CHECK([if PF_INET6 is available], squid_cv_pf_inet6,
+- AC_RUN_IFELSE([AC_LANG_SOURCE([[ /* PF_INET6 available check */
++ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[ /* PF_INET6 available check */
+ # include <sys/types.h>
+ # include <sys/socket.h>
+ int main(int argc, char **argv) {
+@@ -2720,7 +2716,7 @@
+ dnl But only usable if it actually works...
+ if test "$use_v4mapped" = "yes" ; then
+ AC_MSG_CHECKING([for IPv6 v4-mapping ability])
+- AC_RUN_IFELSE([AC_LANG_SOURCE([[ /* IPPROTO_V4MAPPED is usable check */
++ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[ /* IPPROTO_V4MAPPED is usable check */
+ # include <sys/types.h>
+ # include <sys/socket.h>
+ # include <netinet/in.h>
+@@ -3165,7 +3161,7 @@
+ dnl copy that crashes with a buffer over-run!
+ dnl
+ AC_CACHE_CHECK(if strnstr is well implemented, ac_cv_func_strnstr,
+- AC_RUN_IFELSE([AC_LANG_SOURCE([[
++ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+@@ -3191,7 +3187,7 @@
+ dnl Test for va_copy
+ dnl
+ AC_CACHE_CHECK(if va_copy is implemented, ac_cv_func_va_copy,
+- AC_RUN_IFELSE([AC_LANG_SOURCE([[
++ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+ #include <stdarg.h>
+ #include <stdlib.h>
+ int f (int i, ...) {
+@@ -3214,7 +3210,7 @@
+ dnl Some systems support __va_copy
+ dnl
+ AC_CACHE_CHECK(if __va_copy is implemented, ac_cv_func___va_copy,
+- AC_RUN_IFELSE([AC_LANG_SOURCE([[
++ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+ #include <stdarg.h>
+ #include <stdlib.h>
+ int f (int i, ...) {
+Index: squid-3.1.4/helpers/negotiate_auth/squid_kerb_auth/configure.in
+===================================================================
+--- squid-3.1.4.orig/helpers/negotiate_auth/squid_kerb_auth/configure.in 2010-07-06 16:11:59.000000000 +0400
++++ squid-3.1.4/helpers/negotiate_auth/squid_kerb_auth/configure.in 2010-07-06 16:12:55.000000000 +0400
+@@ -367,13 +367,13 @@
+
+ CPPFLAGS="$CPPFLAGS -I../../../ -I../../../include/ -I$squid_dir/include -I$squid_dir/src -I$squid_dir"
+ AC_CACHE_CHECK([for SQUID at '$squid_dir' ],ac_cv_have_squid,[
+-AC_TRY_RUN([
++AC_TRY_COMPILE([
+ #include <config.h>
+ int main(int argc, char *argv[]) {
+ #ifdef SQUID_CONFIG_H
+ return 0;
+ #else
+-return 1;
++boom!
+ #endif
+ }],
+ ac_cv_have_squid=yes,
diff --git a/recipes/squid/squid-3.1.4/squidv3-build-cf_gen.patch b/recipes/squid/squid-3.1.4/squidv3-build-cf_gen.patch
new file mode 100644
index 0000000000..955acf8007
--- /dev/null
+++ b/recipes/squid/squid-3.1.4/squidv3-build-cf_gen.patch
@@ -0,0 +1,33 @@
+Index: squid-3.1.4/configure.in
+===================================================================
+--- squid-3.1.4.orig/configure.in 2010-05-30 17:21:49.000000000 +0400
++++ squid-3.1.4/configure.in 2010-07-06 15:41:52.000000000 +0400
+@@ -2116,6 +2116,10 @@
+ ;;
+ esac
+
++dnl Define BUILD_CXX
++BUILD_CXX="$BUILD_CXX"
++AC_SUBST(BUILD_CXX)
++
+ dnl Check for programs
+ AC_PROG_CPP
+ AC_PROG_INSTALL
+Index: squid-3.1.4/src/Makefile.am
+===================================================================
+--- squid-3.1.4.orig/src/Makefile.am 2010-05-30 17:21:11.000000000 +0400
++++ squid-3.1.4/src/Makefile.am 2010-07-06 15:42:29.000000000 +0400
+@@ -751,6 +751,13 @@
+ squid.conf.default squid.conf.documented: cf_parser.cci
+ true
+
++BUILD_CXX ?= @BUILD_CXX@
++
++cf_gen$(EXEEXT): $(cf_gen_SOURCES) $(cf_gen_DEPENDENCIES)
++ $(BUILD_CXX) -o $@ $(srcdir)/cf_gen.cc \
++ $(top_srcdir)/lib/util.c $(top_srcdir)/compat/assert.cc \
++ -DNDEBUG -DBUILD_HOST_TOOL ${INCLUDES}
++
+ cf_parser.cci: cf.data cf_gen$(EXEEXT)
+ ./cf_gen cf.data $(srcdir)/cf.data.depend
+