aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb')
-rw-r--r--recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb b/recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb
new file mode 100644
index 0000000000..1591b09aba
--- /dev/null
+++ b/recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Debian's start-stop-daemon utility"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "PD"
+PR = "r0"
+
+SRC_URI = "file://start-stop-daemon.c"
+
+S = "${WORKDIR}"
+
+do_configure() {
+ :
+}
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} ${WORKDIR}/start-stop-daemon.c -o start-stop-daemon
+}
+
+do_install () {
+ install -d ${D}/${base_sbindir}
+ install -m 0755 ${S}/start-stop-daemon ${D}/${base_sbindir}/start-stop-daemon
+}