summaryrefslogtreecommitdiffstats
path: root/recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb')
-rw-r--r--recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb b/recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb
index 1591b09aba..6ea0346e6e 100644
--- a/recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb
+++ b/recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Debian's start-stop-daemon utility"
SECTION = "base"
PRIORITY = "optional"
LICENSE = "PD"
-PR = "r0"
+PR = "r1"
SRC_URI = "file://start-stop-daemon.c"
@@ -18,5 +18,13 @@ do_compile() {
do_install () {
install -d ${D}/${base_sbindir}
- install -m 0755 ${S}/start-stop-daemon ${D}/${base_sbindir}/start-stop-daemon
+ install -m 0755 ${S}/start-stop-daemon ${D}/${base_sbindir}/start-stop-daemon.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${base_sbindir}/start-stop-daemon start-stop-daemon start-stop-daemon.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove start-stop-daemon start-stop-daemon.${PN}
}